Delphi - Linea de Codigo que no compila

 
Vista:

Linea de Codigo que no compila

Publicado por eDuM (6 intervenciones) el 31/08/2005 15:47:30
En un simple programa tengo algunas lineas que al compilar no las toma en cuenta. (No aparece el punto azul a su izquierda). Obviamente al ejecutar, esas lineas tambien las saltea. Las linea son simples calculos. Ej: RI := R DIV 256; //(R, RI : Integer)
Alguien sabe que puede ser esto? Si necesitan mas datos o preguntarme algo para aclarar mi duda, haganlo, yo voy a responder a la brevedad.
Gracias de antemano.
Saludos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Linea de Codigo que no compila

Publicado por mamcx (533 intervenciones) el 31/08/2005 16:13:01
Eso ocurre porque el compilador detecta (o supone?) que la linea de codigo no hace nada util (por eso no se le pone el punto azul a begin ni a end)

Tambien puede ser que tengas .dcu que estan en conflicto, por ejemplo, dos mismas .dcu que chocan entre los paths del proyectos, los paths de windows y los de delphi.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Linea de Codigo que no compila

Publicado por eDuM (6 intervenciones) el 31/08/2005 16:19:06
OK, gracias mamcx, voy a controlar las dcu que tenga y verificar eso...
saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Linea de Codigo que no compila

Publicado por Delfino (1222 intervenciones) el 31/08/2005 21:46:27
Este hecho del q habla mamcx se llama optimizacion, si quieres q la compile desactive la casilla correspondiente en las opciones de compilacion..
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Linea de Codigo que no compila

Publicado por eDuM (6 intervenciones) el 01/09/2005 16:17:22
Gracias Delfino. Asi es, colgue el formulario en un proyecto anterior que tenia, y compila todo perfecto. Compare luego las opciones de proyecto del viejo con las del nuevo y efectivamente, habia diferencias en la parte de opciones de compilacion. Gracias por la colaboracion, y si a alguien le sucede esto, ya saben verifiquen bien la propiedades del proyecto.
Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar