Excel - contar veces que se repite una cadena dentro de otra cadena

 
Vista:
sin imagen de perfil

contar veces que se repite una cadena dentro de otra cadena

Publicado por lolo (23 intervenciones) el 24/10/2016 23:56:35
hola,

tengo una tabla donde una de sus columnas tiene varios nombres en cada fila. tiene otra columna con nombres individuales y necesito contar las veces que se repite un nombre solo dentro del campo de varios nombres, es decir:

columna A
nombre 1, nombre 2, nombre 3
nombre 4,nombre 1, nombre 2
nombre 1, nombre 5,nombre 2
nombre 3, nombre 4, nombre 1

columna B
nombre 1
nombre 2
nombre 3
nombre 4
nombre 5

necesito contar la cantidad de veces que aparece cada nombre de B en la columna A.

me debe devolver:
mi cuenta(nombre 1)=4
mi cuenta(nombre 2)=3
mi cuenta(nombre 3)=2
mi cuenta(nombre 4)=2
mi cuenta(nombre 5)=1

yo 1ro uso la funcion hallar y despues contar.si. pero para la funcion hallar debo utilizar tantas celdas como tenga en mi tabla. quisiera hacerlo en una sola celda, algo asi como =CONTAR.SI(HALLAR()) pero no lo logro.

me pueden ayudar?

gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.578
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

contar veces que se repite una cadena dentro de otra cadena

Publicado por wordexperto.com (2288 intervenciones) el 25/10/2016 08:21:04
Hola Lolo:
A mi entender, lo que debes hacer es cambiar la estructura de tu libro. En cada celda solo debe haber un dato, como en la columna B. Si en la columna A tienes que poner varias veces Nombren, añade filas, te recuerdo que en Office 2016, sin complementos, hay más de un millón. Para distinguirlos usa otra, u otras, columna con los criterios que necesites, como ejemplo la fecha. De esta manera, convirtiendo en tabla y filtrando, o con tablas dinámicas tendrás todas las soluciones sin necesidad de fórmulas.
Los libros se estructuran como se deben, bases de datos con formato tabla, y los resultados se obtienen, como necesites verlos, con filtros o tablas dinámicas.
Cambia la estructura, añade columnas y un dato por celda en su columna correspondiente.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil

contar veces que se repite una cadena dentro de otra cadena

Publicado por lolo (23 intervenciones) el 26/10/2016 09:55:37
tu consejo no me ayuda. no puedo cambiar las tablas. Estas hojas de calculo son reportes

que se extraen de una base de datos muy grande que no tengo forma de cambiar. el sistema

es asi. tengo que resolver si o si con los reportes como vengan. gracias por el intento.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 305
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

contar veces que se repite una cadena dentro de otra cadena

Publicado por GMG (119 intervenciones) el 25/10/2016 09:55:21
hola lolo, entiendo que en una misma celda no hay dos registros iguales, p ejemplo:

nombre 1, nombre 1, nombre 2

Si no hay repetidos en una misma celda, lo puedes hacer con un contar.si utilizando los " * "

Ejemplo:

=CONTAR.SI(A1:A4;"*nombre 1*")

Si tienes los nombres en la columna B, has de añadirles los * antes y después:

=CONTAR.SI(A1:A4;"*"&B1&"*")

Saludos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil

contar veces que se repite una cadena dentro de otra cadena

Publicado por lolo (23 intervenciones) el 26/10/2016 09:54:47
no, no hay datos repetidos,

Esto es lo que necesitaba, me ayuda muchisimo. muchas gracias GMG.

ahora necesito complicarlo. pudiera añadir un segundo criterio? por ejemplo que ademas

del criterio ya establecido, en C1:C4 fuera igual a D1?

como lo pongo con 2 criterios?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 305
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

contar veces que se repite una cadena dentro de otra cadena

Publicado por GMG (119 intervenciones) el 26/10/2016 10:37:23
Hola lolo, me puedes poner un ejemplo, te podré ayudar mejor.

Te paso un ejemplo, en la hoja segundo ejemplo:

El tema es que en el ejemplo cuenta únicamente cuando en la misma fila se cumplen las dos condiciones, y no sé si es lo que quieres.

Saludos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil

contar veces que se repite una cadena dentro de otra cadena

Publicado por lolo (23 intervenciones) el 27/10/2016 18:06:43
perfecto! lo que necesitaba!

con la funcion CONTAR.SI.CONJUNTO() resuelvo mi problema.

he tratado de valorar la respuesta pero solo me deja poner 1.

gracias mil
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar