Excel - Problema con formula excel

 
Vista:

Problema con formula excel

Publicado por Mónica (2 intervenciones) el 07/12/2016 11:40:13
Tengo un problema con una fórmula excel que me devuelve falso en vez del valor que corresponde la pongo aquí

1
=SI(A2="3.1";(SI(Y(C13<=5000);'TARIFAS GAS'!B30;SI(Y(C13>5000);'TARIFAS GAS'!B31;SI(A2="3.2";(SI(Y(C13<=5000);'TARIFAS GAS'!B30;SI(Y(C13>5000);'TARIFAS GAS'!B31))))))))

si yo pongo solamente la parte del 3.1 con todas sus condiciones me devuelve el valor de la celda indicada, pero cuando añado la condición de 3.2 me devuelve falso, no se como solucionarlo.

gracias de antemano
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.373
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Problema con formula excel

Publicado por wordexperto.com (2804 intervenciones) el 07/12/2016 12:24:47
Hola Mónica:
Menudo lio de fórmula tienes:
Con esto es suficiente: =SI(A2="3.1";SI(C3>5000;B31;B30);SI(C3>5000;B30;B31)), donde yo pongo b30 y b31 sería 'TARIFAS GAS'!B30 o 'TARIFAS GAS'!B31
E incluso menos, puesto que las tarifas en ambos casos son iguales. Están referenciadas a la misma celda. Simplemente te valdría con: =SI(C3>5000;B31;B30)
El Y se usaría si hubiera más de una condición lógica, que no es tu caso.
cualquier cosa me comentas o sube un libro de ejemplo.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de Antoni Masana
Val: 4.908
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Problema con formula excel

Publicado por Antoni Masana (2492 intervenciones) el 07/12/2016 12:38:01
La formula correcta seria asi:

1
=SI(O(A2="3.1";A2="3.2");SI(C13<=5000;'TARIFAS GAS'!B30;'TARIFAS GAS'!B31);"")

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Problema con formula excel

Publicado por Mónica (2 intervenciones) el 09/12/2016 10:30:31
Muchísimas gracias funciona
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar