Excel - Calcular horas entre dos fechas con rangos de horarios

 
Vista:

Calcular horas entre dos fechas con rangos de horarios

Publicado por beker (1 intervención) el 30/03/2017 07:28:08
Requiero de vuestra ayuda para poder generar reportes de niveles de servicio (atención y solución) de tickets por medio de Excel.

La cobertura de servicio es lunes a sábado de 08:30am a 18:30pm
El nivel de servicio para la atención es de tres horas
y el tiempo de solución es de 8 horas.

El problema es que una simple resta no me sirve ya que requiero descontar los horarios que están fuera de cobertura de las 18:31pm a las 08:29 am del día siguiente además de excluir todo el sabado y domingo. La formula “dias.lab” tampoco me funciona porque este cuenta días completos y se requiere que el resultado sea mas detallado en horas y minutos para confirmar si el reporte estuvo dentro de los niveles acordados.

La base de datos me da la fecha y hora de asignación, la de atención y la de cierre.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 5.157
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Calcular horas entre dos fechas con rangos de horarios

Publicado por wordexperto.com (1767 intervenciones) el 30/03/2017 12:55:39
Hola Beker:
Una solución es añadir una columna Fecha creación corregida, para hacer las restas, con esta fórmula: =SI(O(DIASEM(D2;2)=7;RESIDUO(D2;1)<$J$1;RESIDUO(D2;1)>$K$1);ENTERO(D2)+1+$J$1;D2)
en j1 está la hora de entrada y en k1 la de salida.
El problema lo puedes tener porque las horas de atención se salen de ese horario. Para corregirlo tendrás que crear otra columna auxiliar similar a la anterior.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Revisar política de publicidad