Excel - Ejecutar fórmula si Checkbox está activo.

 
Vista:

Ejecutar fórmula si Checkbox está activo.

Publicado por Antonio (2 intervenciones) el 18/07/2018 11:02:20
Hola!

Es algo muy sencillo pero soy novato y no se nada de VB.

Lo que quiero es hacer una factura con IVA y retención. El problema es que solo algunas facturas llevan retención por lo que, para hacer solo una plantilla de factura que se autorrellene, la casilla de la retención debe ejecutarse solo cuando el usuario lo requiera. Ejemplo:

(A1) Concepto1: 100
(A2) Concepto2: 100
-----------------------------
(A3) Suma: =A1+A2
(A4) IVA: =A3*0,21
(A5) Retención: =A3*0,05
----------------------------
(A6) Total: =A3+A4-A5

Para solucionar el problema se me ocurrio colocar un checkbox en (B5), la valicación en (C5) y en la fórmula de (A5) una condicional, quedaría: =SI(C5="VERDADERO";A3*0,05;0)

No funciona, a lo mejor he hecho una tontería pero creo que debería funcionar. ¿Se os ocurre otra solución? ¿O véis el fallo?

Saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.109
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Ejecutar fórmula si Checkbox está activo.

Publicado por wordexperto.com (2092 intervenciones) el 18/07/2018 11:44:05
No te funciona, Antonio, por las comillas. En este caso, verdadero no es un texto, es un valor. Por esto no necesita comillas.
https://wordexperto.com/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Ejecutar fórmula si Checkbox está activo.

Publicado por Antonio (2 intervenciones) el 18/07/2018 11:48:31
Será posible!!! Sabía que no era un texto normal y tenía algo que ver, pero lo de las comillas me parecía correcto ains. Mil gracias!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar