Excel - Consulta sobre programación "compleja" en Excel

 
Vista:
sin imagen de perfil
Val: 6
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Consulta sobre programación "compleja" en Excel

Publicado por Carlos (3 intervenciones) el 06/08/2018 14:18:01
Hola, que tal estáis?
Es mi primer post... así que siento si no cumplo con los protocolos del foro :P

Tengo una consulta sobre una tabla de excel:

Estoy haciendo un plan económico financiero y en una de las secciones tengo que calcular el impuesto de sociedades.

Este impuesto de sociedades no se cobra hasta que la empresa empiece a conseguir beneficios por lo que la fórmula sería la siguiente:

=SI(C17>0;C17*0.15;0)

Siendo C17 los beneficios preimpuestos mensuales y 0.15 el porcentaje correspondiente a este impuesto.

El problema viene en que al segundo año de dar beneficios el porcentaje pasa a ser del 0.15 al 0.25.

¿Como podría reflejarlo en la fórmula para que se calcule de forma automatizada? Había pensado en darle valor numérico a los meses y hacer un segundo condicional en el que si la suma de meses dando beneficios es superior a 24 C17*0.25, pero no se representarlo.

Muchísimas gracias (:
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Ignacio
Val: 736
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Consulta sobre programación "compleja" en Excel

Publicado por Ignacio (205 intervenciones) el 06/08/2018 19:42:18
Hola:

puedes utilizar la función SIFECHA. Suponiendo que la fecha inicial esta en B1, sería algo así:

1
=SI(SIFECHA(B1,HOY(),"m")>24,C17*0.25,C17*0.15)

Otra forma podría ser:

1
=SI((AÑO(AHORA())-AÑO(B1))*12+MES(AHORA())-MES(B1)>24,C17*0.25,C17*0.15)

Mi separador de argumentos es la "," cámbialo si utilizas otro.



Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 6
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Consulta sobre programación "compleja" en Excel

Publicado por Carlos (3 intervenciones) el 06/08/2018 20:40:21
Muchas gracias, pero este caso solo funciona si no se tiene en cuenta que el impuesto de sociedades ha de ser 0 hasta el primer mes en el que la empresa empiece a dar beneficios.

Realmente no se si puede llegar a hacerse de alguna forma...

Las ideas principales serían las siguientes:

-La empresa va a tener pérdidas durante X meses, durante estos meses el valor por el que se multiplica C17 se mantendrá en 0.
-El primer mes que empiece a dar beneficios el valor de C17 comienza a multiplicarse por 0,15.
-Pasados dos años desde el primer mes con beneficios C17 pasa a multiplicarse por 0,25.

¿Es posible que se pueda englobar todo esto de alguna forma?

Adjunto la hoja de cálculo por si queréis trastear con los valores.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Ignacio
Val: 736
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Consulta sobre programación "compleja" en Excel

Publicado por Ignacio (205 intervenciones) el 06/08/2018 21:00:47
Solamente tienes que meterle otra condición, si es igual o menor a 0 que lo deje en 0

1
=SI(C17<=0,0,SI((AÑO(AHORA())-AÑO(B1))*12+MES(AHORA())-MES(B1)>24,C17*0.25,C17*0.15))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
sin imagen de perfil
Val: 6
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Consulta sobre programación "compleja" en Excel

Publicado por Carlos (3 intervenciones) el 06/08/2018 21:18:34
Muchísimas gracias, jamás habría podido sacarlo solo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar