Excel - Ayuda con formula

 
Vista:
sin imagen de perfil
Val: 42
Ha disminuido su posición en 4 puestos en Excel (en relación al último mes)
Gráfica de Excel

Ayuda con formula

Publicado por Zurki (31 intervenciones) el 07/08/2018 12:47:22
hola amigos...estoy dandole vueltas a la formula que tengo y no sé porque no me funciona la formula que tengo puesta, el caso es que necesito que me ponga el ultimo resultado en B2 y no lo hace.
Puede alguien indicarme donde esta el fallo. Les adjunto ejemplo para que lo vean mejor.

gracias y salu2
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.138
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Ayuda con formula

Publicado por Antoni Masana (1476 intervenciones) el 07/08/2018 13:28:49
Tienes varios fallos.

1
=SI(B4=0;0;INDICE(B4:B30;CONTAR.SI(A4:A30;">0")+CONTAR.SI(A4:A30;"<0")))

Tienes que contar la columna A porque la B tienes Saldo 0 y no cuenta bien.
De la columna A hay que contar por un lado los positivos y por otro los negativos.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
sin imagen de perfil
Val: 42
Ha disminuido su posición en 4 puestos en Excel (en relación al último mes)
Gráfica de Excel

Ayuda con formula

Publicado por Zurki (31 intervenciones) el 07/08/2018 15:59:07
Hola Antoni...muchas gracias de nuevo por tu ayuda para resolver mi problema. Un placer tratar con personas como usted.

Salu2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Ignacio
Val: 705
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Ayuda con formula

Publicado por Ignacio (205 intervenciones) el 07/08/2018 17:57:42
1
=INDICE(B4:B29,K.ESIMO.MAYOR(SI(B4:B29>0,FILA(B4:B29)-3),1))

Es fórmula matricial (Ctrl+Shift+Enter)


Mi separador de argumentos es la "," cámbialo si utilizas otro.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar