Excel - problemas con función si

 
Vista:
sin imagen de perfil
Val: 9
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

problemas con función si

Publicado por Rodrigo (2 intervenciones) el 09/10/2018 05:21:44
buenas tardes

tengo problema con la función si, la cual al ponerlo =SI(Y(H133="FLASH",G133>=A133,N133<"15:45"),"EN TIEMPO","FUERA DE LAT") siempre me marca "EN TIEMPO" aunque este fuera del tiempo.

si me pueden ayudar estaria muy agradecido.

Saludos
error-si
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.146
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

problemas con función si

Publicado por Antoni Masana (1456 intervenciones) el 09/10/2018 07:36:00
Viendo la condiciones del Y() supongo que las dos primeras están bien, es decir se compara dos textos y dos fechas en formato fecha.
Ahora bien la tercera condición está mal, se compara una hora con un texto.
Excel guarda las horas en formato de número, 1 segundo es igual a esta formula 1 / ( 24 * 60 * 60 ) o lo que es lo mismo 1 / 86400.

¿Como compara Excel estos dos campos que son tipos diferentes? Es un misterio insondable.

Solución:

1
=SI(Y(H133="FLASH",G133>=A133,N133<VALOR("15:45")),"EN TIEMPO","FUERA DE LAT")

Así conviertes el texto en formato Hora.

Saludos
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 9
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

problemas con función si

Publicado por Rodrigo (2 intervenciones) el 09/10/2018 07:59:42
Gracias, si me di cuenta de mi error un tiempo después, y ya para cuando hay cambio de variables, tuve que crear otra funcion si anidando las demás funciones, gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar