Excel - redondear a medios (0.5) a partir de .29 a 0 y .7 a 1

 
Vista:

redondear a medios (0.5) a partir de .29 a 0 y .7 a 1

Publicado por Osiris (2 intervenciones) el 12/09/2019 20:56:37
Buenas tardes.

Lo que quisiera es que me apoyen con poder resolver esto en EXCEL, poder redondear de la siguiente manera

entre
12.57 a 12.50 → 0.00 y 0.25 redondee → 0.00
16.29 a 16.50 0.26 y 0.50 redondee → 0.50
09.70 a 09.50 0.50 y 0.75 redondee → 0.50
16.10 a 16.00 0.76 y 0.99 redondee → 1.00
13.80 a 14.00

espero me puedan apoyar, ya que aun no logro poder realizarlo, si es necesario hacer macros o funciones adicionales , de favor...

alguien que me ayude.

Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Andres Leonardo
Val: 3.890
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

redondear a medios (0.5) a partir de .29 a 0 y .7 a 1

Publicado por Andres Leonardo (1475 intervenciones) el 12/09/2019 21:05:25
Disculpa pero no entiend o:S


12.57 a 12.50 → 0.00 y 0.25 redondee → 0.00 ?? que relacion tiene 12.57 a 12.50 -- ? de 0.00 y 0.25 no entiendo la relacion.
16.29 a 16.50 0.26 y 0.50 redondee → 0.50
09.70 a 09.50 0.50 y 0.75 redondee → 0.50
16.10 a 16.00 0.76 y 0.99 redondee → 1.00
13.80 a 14.00
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

redondear a medios (0.5) a partir de .29 a 0 y .7 a 1

Publicado por Osiris (2 intervenciones) el 12/09/2019 21:24:52
Lo que quise decir es poder poner los decimales asi
De 0.45 a 0.5 solo poner en medios o enteros...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Andres Leonardo
Val: 3.890
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

redondear a medios (0.5) a partir de .29 a 0 y .7 a 1

Publicado por Andres Leonardo (1475 intervenciones) el 12/09/2019 23:39:22
Mira si esto es lo que deseas... si no soilo deberias ajustar los rangos...

Adicional en las celdas primeras es para que veas el paso a paso en la E esta en una sola Celda


redondeo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Hector Madriz
Val: 798
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

redondear a medios (0.5) a partir de .29 a 0 y .7 a 1

Publicado por Hector Madriz (137 intervenciones) el 13/09/2019 05:59:05
Buen dia, prueba esto:

Debes establecer los rangos a tu criterio
1
=SI(Y(A2-ENTERO(A2)>0,28;A2-ENTERO(A2)<0,76);ENTERO(A2)&",50";SI(A2-ENTERO(A2)>=0,76;ENTERO(A2)+1;ENTERO(A2)))

Adjunto ejemplo:

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar