Excel - cómo ordenar lista sin repeticiones sin usar fórmulas complicadas

 
Vista:
Imágen de perfil de celia
Val: 716
Bronce
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

cómo ordenar lista sin repeticiones sin usar fórmulas complicadas

Publicado por celia (324 intervenciones) el 17/08/2020 18:59:16
Hola

¿Hay alguna fórmula para ordenar una pequeña lista de texto sin valores duplicados?
He visto la fórmula UNIQUE que parece que sería ideal pero no funciona en mi excel 2019 ni en el 2016 que probé también.

Por más que busco solo encuentro porceso largos que usan varias columnas y fórmulas que luego ni sé replicar en mi hoja como esta por ejemplo

=INDICE(Lista[VALORES];AGREGAR(15;6;SI(FRECUENCIA(COINCIDIR(Lista[VALORES];Lista[VALORES];0);COINCIDIR(Lista[VALORES];Lista[VALORES];0))>0;FILA(Lista[VALORES])-FILA($B$3)+1;NOD());FILAS($D$3:D3)))

Adjunto hoja con un ejemplo de una macro que si funciona pero hay que ejecutar la macro cada vez y me gustaría poder usar una fórmula en las celdas que saquen los valores únicos de la lista cada vez que cambie la lista origen

Muchas gracias por la ayuda.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 147
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

cómo ordenar lista sin repeticiones sin usar fórmulas complicadas

Publicado por Luis (20 intervenciones) el 18/08/2020 09:29:16
Hola adjunto archivo con formula
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de celia
Val: 716
Bronce
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

cómo ordenar lista sin repeticiones sin usar fórmulas complicadas

Publicado por celia (324 intervenciones) el 18/08/2020 12:56:19
Al final creo que usaré el otro método de la tabla dinámica que resolviste también.

Muchas gracias x 2 Luis
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de celia
Val: 716
Bronce
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

cómo ordenar lista sin repeticiones sin usar fórmulas complicadas

Publicado por celia (324 intervenciones) el 24/08/2020 11:03:34
Encontré una forma de hacerlo,
Por si le sirve a alguien más para no perder horas de búsquedas y pruebas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar