Excel - pregunta nula

 
Vista:
Imágen de perfil de Antoni Masana
Val: 4.908
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

pregunta nula

Publicado por Antoni Masana (1790 intervenciones) el 30/12/2020 11:41:37
Buenas Celia,

No se cuantos libros ni cuantas macros tienes ni si este es un nuevo libro o un apartado del mismo libro.

Te comento esto porque la solución para este problema es una macro que se auto-ejecute, lo que podría entrar en conflicto si ya existe otra en la misma hoja o se ejecuta manualmente.

No es posible hacerlo con una formula, bueno es este caso muchas, porque a la que cambies los valores de A2, B2 o C2 el valor sale de un sitio y se pone en otro.

Doy por hecho que las 24 tablas están en el rango F3:CV19. Falta saber si la macro la quieres automática o manual.

Más tarde te paso la macro.

Saludos.
\\//_

P.D.: He visto tu otro correo y me corrijo, no es poner el valor de B5 en las coordenadas correspondientes, es poner el valor de las coordenadas en B5.
Quizás si se podría hacer con Formulas, con macro seguro pero deja que me lo piense.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Imágen de perfil de celia
Val: 761
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

pregunta nula

Publicado por celia (394 intervenciones) el 30/12/2020 11:47:27
Genial Antoni. Si puede ser automática mucho mejor. Es una parte de la hoja en la que tengo más macros pero son manuales todas
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 4.908
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

pregunta nula

Publicado por Antoni Masana (1790 intervenciones) el 30/12/2020 15:38:36
Prueba con esta formula:

1
2
=SI.ERROR(DESREF(F3 ;B2;C2-1+COINCIDIR($A$2;$F$3:$CV$3  ;0)-1;1;1);
          DESREF(F12;B2;C2-1+COINCIDIR($A$2;$F$12:$CV$12;0)-1;1;1))

En la formula he supuesto que B2 es la fila y C2 la columna.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Imágen de perfil de celia
Val: 761
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

pregunta nula

Publicado por celia (394 intervenciones) el 30/12/2020 16:13:56
Inmejorable !!! No creí que fuera posible hacerlo sin código pero me sorprendiste de nuevo.

Un millón de gracias más Antoni y felices fiestas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Andres Leonardo
Val: 3.136
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

pregunta nula

Publicado por Andres Leonardo (1541 intervenciones) el 30/12/2020 16:28:40
te conteste en otra preguntsa mira si puedes

solo se usan unos valores adicionales
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar