PHP - Inconveniente con versión de PHP a producción

 
Vista:
sin imagen de perfil
Val: 24
Ha aumentado su posición en 5 puestos en PHP (en relación al último mes)
Gráfica de PHP

Inconveniente con versión de PHP a producción

Publicado por Cristian Alexis (9 intervenciones) el 15/05/2018 22:08:40
Buenas tardes amigos!


Aun no tengo la suficiente experiencia para tomar decisiones apropiadas o las mas adecuadas como en el siguiente caso, resulta que he desarrollado un sistema web en PHP 7.1 para la administración de recursos o becas para estudiantes de un municipio de mi región y resulta que el servidor cuenta con PHP 5.3.3.

Bien pues se presentaron errores de compatibilidad debido a lo anterior. Se bien que el error es de mi parte pero hubieron algunos problemas de comunicación con el cliente para obtener requisitos etc.

Que acción me recomiendan hacer? He consultado y me parece que Docker podría ser la solución, que opinan ustedes?


Les agradezco mucho por sus opiniones y como dice el dicho... del error se aprende
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve
Val: 3.084
Oro
Ha mantenido su posición en PHP (en relación al último mes)
Gráfica de PHP

Inconveniente con versión de PHP a producción

Publicado por xve (6933 intervenciones) el 16/05/2018 07:41:51
La versión 5.3 del PHP es muy vieja...

Cuando dices de instalar docker, te refieres en el servidor donde se encuentra el PHP 5.3?
Hay que ver que sistema operativo tiene dicho servidor, ya que si es un linux muy antiguo, seguramente tendrás problemas al instalar docker.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 24
Ha aumentado su posición en 5 puestos en PHP (en relación al último mes)
Gráfica de PHP

Inconveniente con versión de PHP a producción

Publicado por Cristian Alexis (9 intervenciones) el 16/05/2018 18:01:53
Ese es mi pensado hasta el momento ya que creo que no es viable una actualización de PHP en el servidor, aunque este si esta en linux y la versión creo no es muy vieja.

No se si hallan mas opciones....


Te agradezco por tu interés.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar