Pseudocódigo/Diagramas de Flujo - ¿Por que no se repite el ciclo?

 
Vista:
Imágen de perfil de Geraldine
Val: 17
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

¿Por que no se repite el ciclo?

Publicado por Geraldine (4 intervenciones) el 02/03/2019 20:01:32
Que tal compañeros? Tengo el siguiente problema:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
Proceso Estudiantes
	//Variables:
	Definir cantNotas, cantEstud, cedula, acum Como Entero
	Definir nombre, apellido Como Caracter
	Definir suma, nota Como Real
 
	//Definimos los valores:
	acum<-1
	suma<-0
	cantNotas<-3
 
	//Ingresamos los datos:
	Escribir 'Ingrese la cantidad de estudiantes'
	Leer cantEstud
	Escribir ''
 
	//Declaramos los vectores:
	Dimension promedio[cantEstud]
 
	Para i<-1 Hasta cantEstud Hacer
		//Ingresamos los datos:
		Escribir 'Ingrese el nombre del estudiante ',i,':'
		Leer nombre
		Escribir 'Ingrese el apellido del estudiante ',i,':'
		Leer apellido
		Escribir 'Ingrese la cedula del estudiante ',i,':'
		Leer cedula
 
		Mientras acum <= cantNotas Hacer
			Escribir 'Ingrese la nota ',acum
			Leer nota
 
			Si nota>20 O nota<0 Entonces
				Escribir 'Ingrese la nota ',acum, ' nuevamente'
				Leer nota
			Fin Si
 
			suma<- suma + nota //Sumamos la nota ingresada a la variable suma
			acum<- acum + 1 //Incrementamos el acumulador
		FinMientras
		promedio[i]<- suma/cantNotas
		Escribir 'El promedio del alumno ',i,' es :', promedio[i]
		Escribir ''
	Fin Para
 
FinProceso

Resulta que, al ingresar a 2 o más alumnos no me deja introducir las notas del siguiente... no se que hacer para resolver el problema.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 13
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

¿Por que no se repite el ciclo?

Publicado por dario dadr200869@gmail.com (9 intervenciones) el 03/03/2019 05:04:50
Hola, debes poner el acumulador dentro del FOR.

1
2
3
4
5
para <condicion>
    acum <- 1
    .
    .
fin-para
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Imágen de perfil de Geraldine
Val: 17
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

¿Por que no se repite el ciclo?

Publicado por Geraldine (4 intervenciones) el 03/03/2019 21:48:16
Gracias amigo! Ahora si me corre perfecto :)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar