Pseudocódigo/Diagramas de Flujo - Detectar una letra en una cadena de enteros

 
Vista:
Imágen de perfil de Geraldine
Val: 14
Ha disminuido su posición en 2 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Detectar una letra en una cadena de enteros

Publicado por Geraldine (4 intervenciones) el 19/03/2019 21:13:02
Buenas tardes compañeros, en la siguiente tarea me mandaron realizar lo siguiente:

"El campo sueldo debe ser numérico con un decimal (no deben permitir valores negativos ni caracteres)"

1
2
3
4
5
6
7
8
9
10
11
12
13
14
Definir sueldo Como Entero
 
Escribir 'Ingrese el sueldo:'
Leer sueldo
 
Si sueldo[<0 Entonces
	Escribir 'Ingrese un monto positivo'
	Leer sueldo
 
			Si sueldo<-0 y sueldo<-9 Entonces
				Escribir 'Ingrese un monto sin letras'
				Leer sueldo
			Fin Si
		Fin Si

Quería saber como puedo detectar si hay letras en una cadena de números. Saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder