Pseudocódigo/Diagramas de Flujo - Realizar un algoritmo para un estacionamiento

 
Vista:

Realizar un algoritmo para un estacionamiento

Publicado por isaac (1 intervención) el 06/08/2020 17:53:27
Realizar un algoritmo para un estacionamiento, en el cual se deben de contabilizar los vehículos que se ingresan al estacionamiento, por lo tanto, deberá de realizar un menú en el que tendrá las siguientes opciones:
1) Vehículo entra
2) Vehículo sale
3) Ver //esta función permitirá ver cuantos vehículos hay en el estacionamiento
4) Salir
Recomendaciones: use una variable de control junto con un bloque de repetición de tipo mientras y para las selecciones puede usar bloques selectores como el bloque si..sino o los casos, todos estos algoritmos deben de elaborarse en PSeInt, también deberá de elaborarse un diagrama de flujos en su cuaderno.
Que debe de enviar: el algoritmo con el formato de archivo de PSeInt, una imagen fotográfica de el diagrama de flujos y al final evidencia fotográfica donde se le vea trabajando en la asignación
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
-1
Responder
sin imagen de perfil
Val: 3
Ha disminuido 1 puesto en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Realizar un algoritmo para un estacionamiento

Publicado por Jorge (2 intervenciones) el 06/08/2020 21:52:31
No indicas que capacidad tendrá el parqueadero, yo le puse 20, queda más o menos así, desde luego hay muchas formas de hacerlo

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
Algoritmo Estacionamiento_Vehículos
	Definir Capacidad, Ocupados, OP Como Entero;
	Definir Placa Como Caracter;
	Capacidad<-20;
	Ocupados<-0;
	Repetir
        // mostrar menu
        Limpiar Pantalla
        Escribir "Menú de Opciones"
        Escribir "   1. Vehículo entra"
        Escribir "   2. Vehículo sale"
        Escribir "   3. Ver"
        Escribir "   4. Salir"
        // ingresar una opcion
        Escribir "Elija una opción (1-4): "
        Leer OP
        // procesar esa opción
        Segun OP Hacer
            1:
                  Si (Ocupados = 20) Entonces
					Escribir "No hay estacionamiento disponible";
				SiNo
					Escribir "Ingresar Placa Vehículo";
					Leer Placa;
					Escribir "Placa Ingresada: ", Placa;
					Ocupados <- Ocupados+1;
				FinSi
            2:
				Escribir "Ingresar Placa Vehículo";
				Leer Placa;
				Escribir "Placa que Sale: ", Placa;
				Ocupados <- Ocupados-1;
            3:
                Escribir "El Número de estacionamientos ocupados es: ", Ocupados;
            4:
                Escribir "Gracias, vuelva pronto"
            De otro modo:
                Escribir "Opción no válida"
        FinSegun
        Escribir "Presione enter para continuar"
        Esperar Tecla
    Hasta Que OP=4
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar