Python - Versiones de python e instalacion de pauqtes

 
Vista:
sin imagen de perfil

Versiones de python e instalacion de pauqtes

Publicado por Jose Antonio (3 intervenciones) el 18/01/2017 01:21:55
Buenas tardes.
Tengo un problema en python que no se como resolver, lo cuento por si alguien tiene alguna pista.
Tengo instalado Centos 7; y hay dos versiones de python (2.7 y 3.5); al instalar un nuevo modulo siempre me lo instala en python 2.7 y con 3.5 no lo puedo usar...
Como Puede soluciones esto??
Muchas gracias.
P.D. Estoy intentando instalar el modulo suds
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve
Val: 1.471
Oro
Ha mantenido su posición en Python (en relación al último mes)
Gráfica de Python

Versiones de python e instalacion de pauqtes

Publicado por xve (1637 intervenciones) el 18/01/2017 08:33:00
Hola Jose, tienes que instalar el modulo para la versión 3 de Python... normalmente, para cada modulo, hay las dos versiones, para la 2.x y para la 3.x

En tu duda, a que modulo haces referencia?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil

Versiones de python e instalacion de pauqtes

Publicado por Jose Antonio (3 intervenciones) el 18/01/2017 15:42:21
Buenas.
Antes de nada, gracias por contestar.
Estoy intentando instalar suds pero al intentar hacerlo me da este error:

[root@localhost bin]# /usr/local/bin/python3.5 -m pip install suds
/usr/local/bin/python3.5: No module named pip
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve
Val: 1.471
Oro
Ha mantenido su posición en Python (en relación al último mes)
Gráfica de Python

Versiones de python e instalacion de pauqtes

Publicado por xve (1637 intervenciones) el 18/01/2017 22:02:08
Hola Jose, tienes que ejecutar:
1
pip3 install suds

Hay un pip para python 2.x y un pip3 para python 3.x
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar