Python - Pasar código a python

 
Vista:
sin imagen de perfil
Val: 27
Ha disminuido 1 puesto en Python (en relación al último mes)
Gráfica de Python

Pasar código a python

Publicado por Mario (10 intervenciones) el 23/01/2020 17:35:48
Hola me podrian ayudar a pasar este código a python:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
SubProceso Promedio ( n1, n2, n3, n4 )
definir prom como real;
 
prom<-(n1*0.20)+(n2*0.25)+(n3*0.25)+(n4*0.30);
escribir "El promedio es : ",prom;
 
Fin SubProceso
Proceso principal
definir n1, n2, n3, n4 como reales;
definir flg como logico;
 
escribir "Bienvenidos al programa de notas!";
escribir "A continuacion se le pedira ingresar las respectivas notas...";
escribir "";
escribir "RANGO PERMITIDO [1.0 - 7.0]";
 
Repetir
escribir "Ingresar la nota 1 : ";leer n1;
escribir "Ingresar la nota 2 : ";leer n2;
escribir "Ingresar la nota 3 : ";leer n3;
escribir "Ingresar la nota 4 : ";leer n4;
escribir "";
 
Si (n1>=1.0 && n1<=7.0)&&(n2>=1.0 && n2<=7.0)&&(n3>=1.0 && n3<=7.0)&&(n4>=1.0 && n4<=7.0) Entonces
flg<-verdadero;
Fin Si
 
Hasta Que flg==Verdadero
 
Promedio(n1,n2,n3,n4);
 
FinProceso
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve
Val: 1.602
Oro
Ha mantenido su posición en Python (en relación al último mes)
Gráfica de Python

Pasar código a python

Publicado por xve (1638 intervenciones) el 24/01/2020 08:00:10
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar