Python - Version de python

 
Vista:
sin imagen de perfil
Val: 3
Ha disminuido su posición en 20 puestos en Python (en relación al último mes)
Gráfica de Python

Version de python

Publicado por Javier (3 intervenciones) el 18/04/2020 02:44:19
Yo tengo instalados 2 python: 2.x y 3.x.

Hoy día recién me di cuenta que mis proyectos en 3.x, al cerrarlos, pasan automáticamente a 2.x (mas específicamente 2.7.13).

¿La solución es quedarme con solo una de las versiones? o ¿Puede ser otra cosa?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de joel
Val: 2.488
Oro
Ha mantenido su posición en Python (en relación al último mes)
Gráfica de Python

Version de python

Publicado por joel (568 intervenciones) el 18/04/2020 08:39:44
Hola Javier, no se entiende esto que comentas de que pasa de la versión 3 a la versión 2...
Puedes tener las dos versiones sin ningún problema... croe que todos los que desarrollamos en Python las tenemos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 3
Ha disminuido su posición en 20 puestos en Python (en relación al último mes)
Gráfica de Python

Version de python

Publicado por Daniel (3 intervenciones) el 18/04/2020 23:37:16
prueba
prueba2

Hago un nuevo proyecto en 3.x lo ejecuto y todo. Al cerrarlo y volver abrir automaticamente se transforma a version 2.x.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 1.847
Oro
Ha mantenido su posición en Python (en relación al último mes)
Gráfica de Python

Version de python

Publicado por tincopasan (565 intervenciones) el 19/04/2020 02:00:49
Estás cometiendo un error enorme, no se transforma! el codigo sigue siendo de python3, lo ejecuta porque en este caso son compatibles.
Lo que debes tener es el interprete de 2.7 por defecto, es decir es el primero que busca.
Ahora, como estás aprendiendo, te recomiendo que descartes 2.7 es una versión que ya no se usa, salvo los grandes proyectos que les costaría migrar a 3.x.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar