Access - Problemas IIF

   
Vista:

Problemas IIF

Publicado por Marta (8 intervenciones) el 04/11/2009 16:36:32
Hola a todos, como andais? Os cuento, llevo un par de dias con esta funcion, la Iif, bueno SiInm (creo que es la misma) os pongo lo que hago:
En una consulta de creacion de tabla tengo un campo que se llama aumAltura

aumAltura: SiInm(([aux_tabique]![altura_obra]<3);0;[aux_tabique]![altura_obra]-3*[aux_tabique]![precio_incr_altura])

La cosa es q si ese campo de altura_obra es menor que 3, el resultado es 0, y sino que le reste 3, y el resultado lo multiplique por el precio del aumento de la altura...

Bueno pues no me da problemas, pero a la hora de crearse esa tabla, ese campo me aparece vacio... y no hay forma de que le de valor, acaso es que no puedo hacer un siInm al crear una tabla????

Estoy desesperada, y no se como hacer esto... Un saludo y gracias de antebrazo.. digo antemano... xD
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas IIF

Publicado por Marta (8 intervenciones) el 05/11/2009 09:24:15
Veo que nadie ve si estoy haciendo algo mal... una lastima... seguire intentando a ver si consigo dar con la solucion... de todas maneras, las respuestas y posibles soluciones son bienvenidas... Un saludo!!!!!!!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas IIF

Publicado por Marta (8 intervenciones) el 05/11/2009 16:28:16
Hola a todos (una vez mas...) creo que se que es lo que le pasa, resulta que antes de hacer esta consulta, hago otra, para guardar otros datos en otra tabla auxiliar, y a raiz de esa tabla auxiliar, sacar otros datos que tambien necesito. En fin, la cosa es, que en la primera consulta me coge la altura de la obra pero me lo guarda en la tabla como dato binario, y no como numerico, el campo del formulario, el textarea, esta como numerico, pero al guardar ese dato en la tabla auxiliar, me lo guarda como binario... entonces claro, al intentar comparar los datos, no me lo compara porque son de diferente tipo.... sabeis como puedo hacer para que no me lo guarde como binario, o es que siempre que guarda un dato de un formulario, lo guarda como tal???

Espero haberme explicado (y que el problema sea ese...) no piloto mucho de access y agradeceria sus respuestas.. Un saludo!!!!!!!!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar