Access - Contador a subformulario con filtro

   
Vista:

Contador a subformulario con filtro

Publicado por Paty (28 intervenciones) el 21/11/2015 00:34:43
Estimados todos, a ver si me pueden ayudar con este problemilla

Tengo un formulario en el tengo 7 controles (comboxes y cajas de texto) para filtrar un subformulario (alimentado por una consulta de unión)

Quiero realizar el conteo de los registros después de aplicados los filtros, estoy utilizando el siguiente código para el conteo:

Me.[Control Subformulario].Form.Recordset.RecordCount

Y para el filtro de texto: Me.subForm.Form.RecordSource = "select * from ConsultaUnion where Nombre like '*" & Me.txtNombre.Text & "*'"

Pero pasa que cuando vacío los filtros, el contador se me descompone y todas las cuentas me las muestra como "6". Pienso que lo que requiero es que el contador tenga un reset una vez que se limpian los filtros, pero no sé cómo aplicarlo.

Si alguno pudiera darme un consejo, mucho se los agradecería
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Contador a subformulario con filtro

Publicado por Enrique Heliodoro (1663 intervenciones) el 21/11/2015 15:37:44
El numero de elementos de un formulario (con origen de datos) se puede conocer consultado a su 'recordsetclone'

En base a ello se presupone que :
Me.[Control Subformulario].Form.RecordsetClone.RecordCount

Debería devolver siempre el numero de registros activos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar

Contador a subformulario con filtro

Publicado por Paty (28 intervenciones) el 23/11/2015 18:48:27
Muchas gracias por tu atención Enrique, fíjate que me sucede exactamente lo mismo :S

Será que no lo estoy colocando en el evento correcto?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Contador a subformulario con filtro

Publicado por Paty (28 intervenciones) el 24/11/2015 01:45:45
Efectivamente Enrique, lo estaba colocando mal. Ya me funcionó de maravilla. Muchas gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar