Access - problema con relaciones

   
Vista:

problema con relaciones

Publicado por MARICRUZ (1 intervención) el 25/09/2007 13:13:28
Hola:
a ver si me podeis echar una mano:
tengo una tabla OBRAS, el campo clave principal ID_OBRA, y despues varios campos mas. Una segunda tabla llamada DOCSOBRA, en la que deben almacenarse todos los documentos relacionados con esa obra. el la clave principal es el campo ID_DOC y he añadido tambien el campo ID_OBRA. y para terminar, hay una tercera tabla que es ACCIONESOBRA que almacena las accciones relacionadas con esta obra y su campo de clave principal es IDACCION y he añadico los campos ID_OBRA Y ID_DOC.

solo os pongo estos campos porque son los que tienen importancia, los demas son datos varios.

Cuando creo las relaciones, el asistente no da ningun error al relacionar:

OBRAS ID_OBRA CON DOCSOBRA ID_OBRA
y tampoco da error en la relacion OBRAS ID_OBRA CON ACCIONESOBRA ID_OBRA.

pero cuando creo un formulario o una consulta, no aparecen los campos de texto.

¿podeis decirme porque me ocurre esto?.
Un beso
Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problema con relaciones

Publicado por Pepe (766 intervenciones) el 25/09/2007 19:06:46
Hola Mari cruz.

Comprueba si los campos son del mismo tipo en todas las tablas.

Supongo que en la tabla OBRAS el ID lo tienes del tipo autonumerico, y en las tablas de DOCSOBRA y ACCIONESOBRA los tienes del tipo texto.

Saludos, Pepe
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar