Access - Campo vinculado entre form y subform

   
Vista:

Campo vinculado entre form y subform

Publicado por Carlos Imaz (6 intervenciones) el 30/11/2007 22:32:54
Buenas noches:

Formulario de centros educativos con varias solapas con diferentes actividades. En cada solapa, un subformulario. Evidentemente, el campo vinculante es el IDCentro y así está configurado en las propiedades de los subformularios "Vincular campos secundarios" y "Vincular campos principales".

El problema es que cuando intento añadir un nuevo registro en cualquiera de los subformularios (que están en formato hoja de datos y con el campo IDCentro oculto), al extender los combos me aparece el mensaje de que el registro necesita una clave relacionada para dicho campo IDCentro.

Supongo que se debe a que el campo oculto está vacío, pero yo pensaba que al indicar dicho campo en las dos propiedades del subformulario arriba indicadas desaparecía este problema.

¿Qué hago mal? ¿Quizás no hay que introducir el campo en alguna de las dos propiedades del subformulario?

Gracias adelantadas
Carlos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Campo vinculado entre form y subform

Publicado por Victoria (1530 intervenciones) el 01/12/2007 12:10:16
Hola:

Antes de intentar añadir un nuevo registro al subform, has de rellenar el campo relacionado del formulario principal (en tu caso, entiendo, elegir el centro)

No comentas nada de como lo haces, así que, mira si este puede ser el problema

Un saludo
Victoria
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Campo vinculado entre form y subform

Publicado por Carlos Imaz (6 intervenciones) el 05/12/2007 14:29:41
Gracias, Victoria, ya lo he conseguido. No sé muy bien porqué, pero a pesar de estar los campos enlazados correctamente, cuando extendía los combos no me dejaba seleccionar ninguna opción al introducir un registro nuevo (curiosamente sí me dejaba rellenar los textbox).

Lo he solucionado un poco a lo chapucero: actualizando el nuevo registro después de rellenar el primer textbox y pasando el foco luego al primer combo, que al estar ya en modo edición sí me deja elegir un elemento del mismo.

Saludos
Carlos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar