Access - Porque sucede esto?

   
Vista:

Porque sucede esto?

Publicado por Facu (56 intervenciones) el 12/02/2008 00:57:13
hola gente...

Hoy habia logrado hacer funcionar una formula para sumar meses a una fecha.
La cual es la siguiente....

=SerieFecha(Año([vFecha]),Mes([vFecha])+1,10)

Logre poner esta formula en un textbox, pero me costo mucho pq me decia que habia un error de sintaxsis pero luego de insistir funciono.

Ahora la quiero copiar a otro textbox, para continuar armando mi informe. Pero no me deja copiarla pq dice que tiene un error de sintaxis.
Porque pasa esto...alguien tiene idea?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Me olvidaba algo!

Publicado por Facu (56 intervenciones) el 12/02/2008 01:03:53
Me olvidaba dos cosas..

Primero es decirles que cuando quiero copiar el texbox con la formula dice que no se puede porque la funcion que quiero introducir tiene un numero incorrecto de argumento.
Como les dije antes ya esta misma formula le habia aceptado no facilmente pero despues de insistir la toma.

Lo segundo que me olvide es de agradecerles por el tiempo invirtidos en mi duda.-

Desde ya mucha Gracias.-
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Porque sucede esto?

Publicado por mi menda (1111 intervenciones) el 12/02/2008 03:13:24
Hola Facu:
Como castigo, escribe 100 veces:

Con la coma no funciona, Utilizaré el punto y coma ;

Un Saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Porque sucede esto?

Publicado por Facu (56 intervenciones) el 12/02/2008 14:43:47
Hola Mi menda....gracias por dedicar tiempo a mi escasa experiencia en Acces.

Pero sabes que si hago esa formula con ";" me pone q existe un error de sintaxis.
Ademas probe hacer otras formulas y en origen de control me las toma con "," Esa formula la tengo que poner en "origen de control" no??
Se te ocurre otra cosa....???

Desde ya muchas gracias.-
Facu.-
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Porque sucede esto?

Publicado por mi menda (1111 intervenciones) el 12/02/2008 20:24:52
Pues lo que te pasa es muy raro, la coma se utiliza en visual basic y el punto y coma en access.
Prueba a poner como origen del informe una consulta y te creas los campos nuevos en la consulta:

Cupon1:SerieFecha(Año([vFecha]);Mes([vFecha])+1;10)

Luego utilizas esos campos en el informe
Prueba la formula con coma y punto y coma. Sí no te funciona, lo comentas, y lo hacemos desde visual basic para evitar errores.

Un Saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Porque sucede esto?

Publicado por Facu (56 intervenciones) el 12/02/2008 22:41:02
Hola mi menda....

Ya el origen del informe es una consulta!! jaja!

saludos.-
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Porque sucede esto?

Publicado por Facu (56 intervenciones) el 12/02/2008 22:53:22
Haber...

=SerieFecha(Año([vFecha]);Mes([vFecha])+1;10)

Estube probando nuevamente la formula, creo que el tema de la "," o ";" es , pq sino no lo acepta.
Ahora para mi el problema de la formula es el "+1" pq cuando lo saco la toma bien a la formula.
Y probe de meter el "+1" dentro del parentesis del mes.....quedandome la formula

=SerieFecha(Año([vFecha]);Mes([vFecha]+1);10)

esta formula la acepta pero cuando voy al informe solo me modifica el dia a 10 pero el mes ni se mosquea.

Se les ocurre algo??

Saludos.-
Facu.-
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Mi menda...ya lo tengo!!

Publicado por Facu (56 intervenciones) el 12/02/2008 23:53:24
Mi menda!!
Sabes donde estaba la falla .....

=SerieFecha(Año([vFecha]),Mes([vFecha])+1,10)

Es que al +1 le tenia que agregar los parentesis!!!quedando la formula....

=SerieFecha(Año([vFecha]),Mes([vFecha])+(1),10)

GRACIAS MI MENDA POR TU TIEMPO INVERTIDO EN MI DUDA!!! Y A TODOS LOS DEMAS TAMBIEN!!
Un Saludo.-

Facu.-

PD. tenes idea de algun tutorial para aprender codigo para acces....pq no tengo ni idea y me gustaria aprender!!! gracias.-
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Mi menda...ya lo tengo!!

Publicado por mi menda (1111 intervenciones) el 13/02/2008 01:56:39
Hola Facu:
Pero que Access más raro tienes.....

Primero leete el manual de Fermí Vila, lo bùscas en el google sín problemas.
Después uno genial de Eduardo Olaz, ya más veces recomendado en el foro.

http://www.olaz.net/

Un Saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar