Algoritmia - intercambio

   
Vista:

intercambio

Publicado por katia (3 intervenciones) el 21/02/2009 18:33:19
hola a todos porfa necesito k me ayuden en este algoritmo..me piden para un trabajo..de antemano los aagradezco. el algoritmo es el siguiente:

ingresar dos palabras de diferentes tamaños e intercambiar las letras de las posiciones pares. es decir asi:
tengo dos palabras por ejemplo:
SOLEDAD
TARAPOTO

la salida del algoritmo debera ser asi:
SALADOD
TOREPATO

es todo ok..aydenme por fa!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:intercambio

Publicado por eduardo (55 intervenciones) el 21/02/2009 21:43:10
- Habría que determinar cual es la cadena más corta.
- En C/C++ la indexación de cada caracter empieza en 0, es decir las posiciones pares desde este punto de vista serían los índices 1, 3, 5, 7, 9, ... (índices impares).

Var:
cad1: Cadena
cad2: Cadena
ptrCad: *Caracter // puntero a caracter
c: Caracter
i: Entero // contador

Inicio
Leer cad1
Leer cad2

// Hacemos que ptrCad apunte a la cadena de menor longitud
ptrCad = cad1
Si ( Len(cad2 < Len(cad1) ) entonces
ptrCad = cad2
Fin_si

i = 0 // inicializa el inidice
Mientras ( ptrCad[i] ) // recorre la menor cadena (donde apunta ptrCad)
Si ( i mod 2 <> 0 ) // si es impar
// intercambiar
c= cad1[i]
cad1[i] = cad2[i]
cad2[i] = c
Fin_Si
Fin_Mientras

Escribir( cad1 )
Escribir( cad2 )

Fin

Bueno ahi tienes tu tarea
Salu2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar