Algoritmia - ayudeme a realizar algoritmo

   
Vista:

ayudeme a realizar algoritmo

Publicado por julian andres (1 intervención) el 17/02/2010 12:30:45
una compañia de celulares tiene la siguiente promocion de 8 am a 12 m y de 2 pm a 6 pm el valor del minuto vale 320, de 6 am a 8 am y 12 m a 2 pm y de 6 pm a 10 pm el valor del minuto vale 350, el resto de las horas vale 290.

REALIZAR UN ALGORITMO QUE LEA NUMERO DE CELULAR, NOMBRE DEL TITULAR, HORA DE LA LLAMADA, DURACION DE LA LLAMADA. MOSTRAR COSTO DE LA LLAMADA NOMBRE DEL TITULAR Y A QUE OPERADOR PERTENECE LA LINEA
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ayudeme a realizar algoritmo

Publicado por marco antonio serrato  (1 intervención) el 21/09/2010 17:45:35
mira el dato es este divide todo en kosas esenciales de 8am a12am y de 2am a 6am variable p=320

6pm a8pm y 12pm a 2pm y 6pm a 10pm variable c=350 sobrante variable s=290

aplicas las variables y subsecuentes otradato que t puede servir es cambiar la forma de horario a 24 horas asii no abria num. repetidos y podria ser mas klaro

lo demas ya aslo tu es solo una ayuda a que se te haga un poko mas klaro
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ayudeme a realizar algoritmo

Publicado por armandogit (1 intervención) el 23/09/2010 16:54:27
bueno nos e nada pero me piden en clase comentar jjejejejejejejej
esa es mi solucion
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ayudeme a realizar algoritmo

Publicado por Marlene Espinosa  (1 intervención) el 24/09/2010 05:07:50
hola compañero!
he hecho un pseudocodigo, tal vez te sirva.

Variables:
numero: almacena el num de celular
titular: almacena el nombre de quien habla
oper._de_lin: almacena al operador de la linea
hrllam: almacena la hora en que se comunica el titular, pero las horas se manejan de la siguiente manera:
100= 1 a.m. ...600 = 6 a.m...1200= 12 p.m... 1800= 6 p.m ....2400 = 24 p.m
tiemp: almecena la duracion de la llamada
costllam: almacena lo que se debe pagar de la llamada

paso1. INICIO
paso2. escriba "deme el num. "
paso3.leer num
paso4. escriba "titular "
paso5. leer titular
paso6.escriba "oper. de lin."
paso7. leer oper._de_lin.
paso8.escribir "hrllam"
paso9.leer hrllam
paso10. mientras (100 => hrllam <= 2400) hacer
escribir "tiemp de llamada"
leer tiemp
si (800<= hrllam < 1200) OR (1400 <= hrllam < 1800) entonces
min = 320
costllam = tiempo * min
en caso contrario
si ( 600 <= hrllam < 800) OR (1200 <= hrllam < 1400) OR (1800 <= hrllam < 2200)entonces
min = 350
costllam = tiempo * min
en caso contrario
si ( 2200<= hrllam < 600) entonces
min = 290
costllam = tiempo * min
fin si
fin si
fin si
fin mientras
paso11. imprimir num
paso12. imprimir titular
paso13. imprimir hrllam
paso14. imprimir costllam
paso.15. imprimir oper._de_lin.
paso16. FIN

Espero te ayude compañero
saludos
hasta pronto
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar