C sharp - Problema con radioButton

   
Vista:

Problema con radioButton

Publicado por Raidel (3 intervenciones) el 20/05/2015 16:08:08
Hola
Estoy usabdo radioButtons en una apliccación. Necesito que cuando se cargue la ventana, todos los radioButton aparescan desmarcados. He probado cambiando el tabIndex y el focus, pero siempre aparece algún de los radioButtons marcados.
Gracias de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Wilfredo Patricio Castillo

Problema con radioButton

Simple:

Radiobutton1.checked=false;
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema con radioButton

Publicado por Raidel (3 intervenciones) el 20/05/2015 23:13:22
Se que eso pudiera resolver mi problema, pero tengo muchos radioButton en la aplicacion y estoy buscando una solución más sencilla que ir uno por uno poniendo la propiedad Checked en false.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Wilfredo Patricio Castillo

Problema con radioButton

También es simple

Te haces un método

recorres los controles del formulario, compruebas que sean radiobutton y lo desjhabilitas.

un simple foreach(Control item in Controls)
{

}

Con eso ya estáría resuelto, dentro solo verifica que sea un radiobutton y ya está.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema con radioButton

Publicado por Raidel (3 intervenciones) el 22/05/2015 15:13:28
Ya hice ese método y no me funciona, siempre me aparece el primer radioButton marcado. Esto fue lo que hice:

checkbox
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Wilfredo Patricio Castillo

Problema con radioButton

Verifica si ese primer radiobotón está dentro de alguno de los contenedores, si te funciona para todos menos el primero, es porque el primero no están ni dentro del panel ni dentro del groupbox que es lo que estás comprobando, caso contrario o funciona para todos o no funciona para ninguno, pero revisa que el primero como te digo esté contenido dentro de los contenedores que mencionas, sino nunca se desmarcará.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar