Clarion - Problema con botones

   
Vista:

Problema con botones

Publicado por Pato (12 intervenciones) el 25/02/2011 15:33:24
Hola a todos, tengo desde hace un tiempo problemas con unos botones que tengo en una barra de tareas de un sistema, estoy con Clarion 6.1.
El tema es el siguiente, yo desde un boton genero una liquidacion mensual que carga la deuda de los usuarios en una tabla.
Despues en otro boton tengo para generar cupones que se imprimen, es con ese boton que tengo problemas, cada 3 o 4 meses deja de funcionar en la maquina de mi cliente, yo lo ejecuto en la mia y funciona todo bien.
Yo pensaba que por ahi los reportes generan algunos temporales que impiden cada tanto que funcionen los botones, o no se, pero es algo extraño que nunca me paso.
Ese mismo reporte lo puse dentro de un menu, para evitar el boton externo, y tampo hace nada, cuando deja de funcionar no hay caso por ningun lado.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Clarion
- Código fuente de Clarion
- Cursos de Clarion
información
Códigos de Clarion
- Llamar al form para insertar desde el menu

RE:Problema con botones

Publicado por Marcelo Madelon (572 intervenciones) el 25/02/2011 15:45:21
Pato

Me suena a error de lógica
¿Como te manejas, con una queue o un archivo?

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con botones

Publicado por Pato (12 intervenciones) el 25/02/2011 15:49:36
pero porque en cualquier maquina sigue funcionando sin ningun problema, lo he probado en mas de 4 maquinas y no he tenido inconvenientes.
Yo una vez que creo la deuda que guardo en una tabla, despues para generar los cupones tomo desde esa tabla, la deuda del periodo que el usuario ingresa y genero los cupones que se imprimen solamente, no se guardan en ningun lado, ellos los pueden generar tantas veces quieran e imprimir.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con botones

Publicado por Marcelo Madelon (572 intervenciones) el 25/02/2011 17:00:10
Probaste traer los archivos a la maquina tuya? para asegurarte de estar trabajando con los mismos archivos. Es posible que en tu oficina haciendo pruebas nunca pases por alguna situación o uses alguna rutina que te genere el error.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con botones

Publicado por Pato (12 intervenciones) el 25/02/2011 17:28:00
si, trabajo con los mismos archivos, es mas, le hago yo los cupones desde mi maquina cuando no le funciona.
Ahora probe de hacer una ventana y desde ahi con unas opciones llamar a los reportes.
Vere si de esta manera funciona, sino ya no se que mas inventar.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con botones

Publicado por Marcelo Madelon  (572 intervenciones) el 25/02/2011 17:54:48
Pato
Es de lo mas extraño

Avisame si lo solucionas por que quedé intrigado.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con botones

Publicado por Diego Hernan (11 intervenciones) el 25/02/2011 19:01:48
Che... perdonen que me meta... pero basado en mi experiencia... no sera error de usuario??? digo... porque es realmente extraño que cada 4 meses se estropee el boton...

No sera que cada 3 o 4 meses hacen algo que interrumpe la funcionalidad del programa? y vos te estas rompiendo la cabeza pensando que hay algo mal y resulta que son los usuarios finales que utilizan el programa quienes tienen la culpa?

Solo opino, pero puede ser una posibilidad...

Saludos

Diego Hernan
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con botones

Publicado por Marcelo Madelon (572 intervenciones) el 25/02/2011 23:23:36
Diego Hernan

Por eso le preguntaba si los archivos eran los mismos.
Ahora hay que pensar hasta en lo mas insolito. Ejemplo si la impresora predeterminada no es un archivo..... No le va a resultar para nada facil

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con botones

Publicado por Pato (12 intervenciones) el 04/03/2011 15:27:09
Hola chicos, gracias por responder, la verdad lo de los botones no pude solucionarlo, opte por ponerle una ventana con 2 opciones, una con cupones totales y otra opcion cupones parciales, hasta ahora funciona, espero que siga asi.
Mil gracias por sus aportes!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar