Crystal Report - No me abre el informe --> "OpenDocument"

   
Vista:

No me abre el informe --> "OpenDocument"

Publicado por Siz (14 intervenciones) el 12/09/2007 11:16:10
Hola amigos, tengo un problema al abrir un informe en remoto.

Estoy utilizando Visual Studio 2003 con una aplicacion web usando el Framework 1.1.4322.

Utilizo el siguiente codigo para abrir un informe :

***********************************************************************************************************
ReportClientDocument informe = new ReportClientDocument();

informe = reportAppFactory.OpenDocument(infoObject.ID, 0);

***********************************************************************************************************

El problema es que al hacer la llamada al OpenDocument se me keda esperando sin llegar abrirlo, hasta que pasa el Timeout de la peticion y salta la excepcion de no poder conectarse debido al sobrepasar el timeout. He de decir que que sí encuentra el informe, ya que en el objeto infoObject.ID guarda perfectamente el ID del informe que se ha pedido, pero no llega a abrirlo con la llamada OpenDocument, se queda esperando, y esperando, y esperando ...

Este mismo codigo es utilizado desde otra aplicacion desarrollada en VS2005 con Framework 2.0 que ataca al mismo informe alojado en el mismo servidor y lo abre perfectamente, pero no se por que desde este otro escenario (VS2003 y Framework 1) no lo hace.

Ya os adelanto que no es problema de permisos al servidor!!

Alguna idea??

Gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:No me abre el informe -->

Publicado por Alejandro (8 intervenciones) el 05/12/2007 18:53:01
el framework dos es lo que te hace falta
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar