Delphi - No jala el campo nombre

   
Vista:

No jala el campo nombre

Publicado por Felipe (3 intervenciones) el 19/09/2007 22:43:07
Hola

Hago esto...

SQL := 'Select Nombre,Departamento from Empleados where Codigo = :codigo and Activo = 1';
Query1.SQL.Text := SQL;
Query1.ParamByName('codigo').AsString := EdNCodigo.Text;
Query1.Active := True;
EdSNombre.text := Query1.Fields[0].AsString;

Pero curiosamente el campo nombre nunca lo jala, en el campo ...Fields[0] deberia venir el nombre del empleado, pero lo que me devuelve numero de departamento que deberia ser ...Fields[1].

La base de datos esta en SQL Server y la estoy accesando por medio de ODBC. El campo nombre es un nvarchar(50)...

Gracias

Hice la pregunta en otro foro

http://www.clubdelphi.com/foros/showthread.php?t=48255

Y nadie supo porque pasaba esto...
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Delphi
- Código fuente de Delphi
- Cursos de Delphi
- Temas de Delphi
- Chat de Delphi
información
Códigos de Delphi
- Árboles Binarios
- Descomposición RGB
- OpenGL

RE:No jala el campo nombre

Publicado por E.T. (1107 intervenciones) el 19/09/2007 23:00:12
Imagino que desactivas el query antes de asignar el nuevo sql??
Prueba solo con el nombre, haber si lo te lo pone, si no, algo debe andar mal tu manejador de base de datos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No jala el campo nombre

Publicado por Felipe (3 intervenciones) el 19/09/2007 23:10:49
Si claro, y de todas formas no lo hace...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No jala el campo nombre

Publicado por E.T. (1107 intervenciones) el 19/09/2007 23:24:33
Puesdes ver tu base de datos en el "SQL Explorer"? ( en el menu database, explore), intenta poner la consulta ahi, para descartar que sea el componente
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No jala el campo nombre

Publicado por jose luis (159 intervenciones) el 20/09/2007 00:39:17
Has probado asignar el campo al edit usando FieldByName('Nombre') en lugar de Fields[0]
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No jala el campo nombre

Publicado por Felipe (3 intervenciones) el 20/09/2007 01:09:18
No, lo voy a probar...

Ahi te aviso, gracias!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar