Dev - C++ - ¿Ayuda con Triangulo de Pascal en Pseint...?

   
Vista:

¿Ayuda con Triangulo de Pascal en Pseint...?

Publicado por JoseCheo joseche0.ja@gmail.com (1 intervención) el 02/05/2013 23:25:30
Este es el ejercicio : El corre bien pero tengo un error xq columna vertical no me muestra solo 1,1,1,1,1 sino q muestra 1,2,3,4,5,6 y x eso no hace la sumatoria de los binomios bien... ayuda porfavor...




SubProceso h <- Factorial ( t )
Si t<2 Entonces
h <-1;
Sino
h <- t * factorial (t-1)
FinSi
FinSubProceso

SubProceso k <- Combinacion ( n , r )
Si r=1 Entonces
k<-n;
Sino
Si n=r Entonces
k<-1;
Sino
k <- Factorial(n) / (Factorial(r) * Factorial(n - r));
FinSi
FinSi
FinSubProceso

Proceso MediaPiramide

Escribir " Cantidad dimensiones"
leer f
Dimension m[f,f]
Para i<-1 Hasta f Hacer
Para j<-1 Hasta i Hacer
Escribir sin saltar Combinacion(i,j);
FinPara
Escribir ""
FinPara

FinProceso
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

¿Ayuda con Triangulo de Pascal en Pseint...?

Publicado por Alejandro Caro (1 intervención) el 21/03/2015 21:20:00
Tenés 2 errores

SubProceso h <- Factorial ( t )
Definir h Como Entero;
Si t<2 Entonces
h <-1;
Sino
h <- t * factorial (t-1);
FinSi
FinSubProceso

SubProceso k <- Combinacion ( n , r)
Definir k Como Entero;
Si r=1 Entonces
k<-n;
Sino
Si n=r Entonces
k<-1;
Sino
k <- Factorial(n) / (Factorial(r) * Factorial(n - r));
FinSi
FinSi
FinSubProceso

Proceso MediaPiramide
Definir f, i, j Como Enteros;
Definir m Como Entero;
//Dimension m[f,f] //<- esta dimensión no tiene sentido, f el una variable entera que se usa como altura de la pirámide no un arreglo
Escribir " Cantidad dimensiones";
Leer f;
Para i <- 1 Hasta f-1 Hacer
Para j <- 0 Hasta i Hacer // <--- a la variable j hay que inicializarla en 0, no en 1
Escribir Sin saltar Combinacion(i,j);
FinPara
Escribir "";
FinPara
FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar