Excel - funcion de tabla

   
Vista:

funcion de tabla

Publicado por Federico (4 intervenciones) el 19/01/2010 16:09:42
Hola! ya hace unos dias escribi en este foro para pedir consejo y me fue muy util, pues hacia mucho que no usaba excel y he perdido conocimientos por el camino jeje.

Esta era mi pregunta de la otra vez
http://www.lawebdelprogramador.com/news/mostrar_new.php?id=127&texto=Excel&n1=552000&n2=1&n3=0&n4=0&n5=0&n6=0&n7=0&n8=0&n9=0&n0=0

Vale, ya he entendido lo de poner si saco 500 cds va a esto, si saco 1000 a esto, lo puse asi
=SI(C3>=500;0,24)+SI(C3>=1000;0,23-0,24)+SI(C3>=2000;0,195-0,23)+SI(C3>=3000;0,19-0,195)

pero tengo un problema, que yo quiero indicarle que 0,24 es cuando va de 500 a 1000, y que no hay que sumarle nada al precio anterior, es decir si salen 1000, no es el importe de 500 mas el de 1000. Para solucionar esto lo que hago es restarle el valor del anteior como se puede comprobar arriba en la formula que he introducido.
Entonces para simplicar y no poner restas en el valor he intentado acotar el valor asi
=SI(500<=C3<1000;0,24)+SI(1000<=C3<2000;0,23)+SI(2000<=C3<3000; 0,195)+SI(3000<=C3<4000;0,19)
Pero no me funciona, asi lo que me hace es sumar todos los importes

Y luego otra pregunta que esa recuerdo que tambien lo sabia hacer pero ahora no recuerdo.
Yo tengo una tabla tambien del libreto (recuerdo que era una tabla para fabricacion de cds), es decir que hay dos condicionantes, depende cantidad de copias y paginas del libreto, y una solucion era ponerlo asi:
=SI(SI(C6=2)Y(C3=500);0,688)+SI(SI(C6=4)Y(C3=500);1)+SI(SI(C6=8)Y(C3=500);0,13)+SI(SI(C6=12)Y(C3=500);0,15)+SI(SI(C6=16)Y(C3=500);0,181)+SI(SI(C6=2)Y(C3=1000);0,73)

Pero claro asi puede ser extremadamente largo pues el libreto puede ser de 2, 4, 8, 12, 16... y mas es raro, y las tiradas de 500, 1000, 2000... o 1300
Entonces recuerdo que habia que añadir en una pestaña la tabla en cuestion con todos los precios y sobre esa tabla se podia luego añadir a la tabla final donde hacer los presupuestos, es decir ponerle el condiconante si en esta casilla pone 12 paginas y en esta otra pone que hay 2000 copias, que vaya a la tabla que he puesto en la otra pestaña y me indique el valor que marca en esa tabla.

Creo que me he explicado bien, pero nunca se sabe

Si alguien me puede ayudar me haria una persona feliz

Gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:funcion de tabla

Publicado por Raziel (243 intervenciones) el 19/01/2010 18:09:42
=SI(500<=C3<1000;0,24)+SI(1000<=C3<2000;0,23)+SI(2000<=C3<3000; 0,195)+SI(3000<=C3<4000;0,19)

Esa formula no te funciona por que su sintaxis esta incorrecta, la forma que utilizas para evaluar la prueba logica esta muy mal, ahi tendrias que utilizar la funcion Y o la funcion O dependiendo de tu necesidad, otra cosas que esta mal es el uso de comas y punto y coma, depende de tu configuracion regional, o usas una o usas otra pero no las 2 a la vez, o por lo menos no en este caso, yo utilizo comas, por ultimo, para tus pretenciones, lo que necesitas es anidar las funciones SI y no sumarlas, entonces estas tendrian que iniciar en la tercera seccion de cada funcion, a continuacion te dejo la sintaxis regular y anidada de esta funcion...

Regular
=SI(prueba_logica,valor_si_verdadero,valor_si_falso)

Anidada (2)
=SI(prueba_logica,valor_si_verdadero,SI(prueba_logica,valor_si_verdadero,valor_si_falso))

Anidada (3)
=SI(prueba_logica,valor_si_verdadero,SI(prueba_logica,valor_si_verdadero,SI(prueba_logica,valor_si_verdadero,valor_si_falso)))

Y asi hasta llegar al tope de 64 anidaciones, esto segun tu version de Excel, como te puedes dar cuenta la 2da, 3ra y demas funciones anidadas se integran en la parte donde iria el valor_si_falso de su antecesor y asi en todos los casos.

Por otra parte, si pretendes anidas muchas condiciones creo que lo mejor que podrias hacer es utilizar la funcion BUSCAR, en la ayuda de excel encontraras muy buena informacion
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar