Excel - Campo Contar Tabla Dinamica

   
Vista:

Campo Contar Tabla Dinamica

Publicado por Eduardo Flores (2 intervenciones) el 22/10/2010 01:22:54
Saludos lobos del excel,

Si tengo por ejemplo el siguiente DataSource:

FECHA CLIENTE DISTRITO VENTA
Ene-2010 0024 Lima 5,0000
Feb-2010 0024 Lima 6,0000
Abr-2010 0024 Lima 6,5000
Ene-2010 0030 Lince 7,0000
Mar-2010 0030 Lince 7,2000
Abr-2010 0034 Lince 6,8000
Feb-2010 0050 Ate 5,8000
Mar-2010 0052 Ate 6,5000
Mar-2010 0054 Ate 6,5000

Como hago para que mi Tabla Dinamica me arroje el siguiente resultado:

Lima 1
Lince 2
Ate 3

Es decir me dé el número de clientes por DISTRITO - NO que los cuente solamente, sino que los cuente sin repetirlos.

Saludos y mil gracias de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Campo Contar Tabla Dinamica

Publicado por Luis Fernando Giraldo (805 intervenciones) el 22/10/2010 02:40:32
Yo pensaría agregar otra columna, por ejemplo en la columna "E" luego de VENTA y en la celda E2 es decir frente a Ene-2010 0024 Lima 5,0000 colocaría la siguiente formulación:

=SI(CONTAR.SI(C$1:C2;C2)>1;0;MAX(E$1:E1)+1)

Luego copiarla a las deldas bajo ella, obteniendo asi en la columna "E" los siguentes resultados

E1 Contador
E2 1
E3 0
E4 0
E5 2
E6 0
E7 0
E8 3
E9 0
E10 0

desde ahi ya si quieres la puedes llevar facilmente a la tabla dinámica.

Cordial saludo desde Pereira Colombia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Campo Contar Tabla Dinamica

Publicado por Eduardo Flores (2 intervenciones) el 22/10/2010 18:16:14
Saludos Luis,

Mil gracias por tu gentil respuesta. Pero, si bien es cierto en el ejemplo con el que formulé la pregunta yo ordené los códigos de cliente; en mi DataSource original todo está en desorden porque es el resultado de una query sql que me arroja más de medio millón de registros y tengo 20 campos distintos.

Mi pregunta iba un poco más orientada a una solución ON-FLOW sobre la misma tabla dinámica, ya que con los valores de venta no tengo problemas, pero cuando necesito contestar preguntas del tipo 'Cuantos' no encuentro por donde.

Tu solución esta ok, pero implicaría ORDENAR primero mi medio millón de registros por código de cliente, luego insertar la columna con el contador y luego generar mi tabla dinámica. Si esta es la única manera de hacerlo, me gustaría saberlo, pero como que el concepto "Tabla Dinámica" pierde un poco su sentido.

Sin embargo, un millón de gracias por tu tiempo y tu valiosa respuesta porque sea como fuere, ya aprendí algo nuevo.

Un saludo fraterno desde Lima - Perú.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Campo Contar Tabla Dinamica

Publicado por Luis Fernando Giraldo (805 intervenciones) el 23/10/2010 04:41:48
Otra posibilidad es colocar la misma formulacion pero en una columna frente a la tabla dinámica, habiendo colocado antes la tabla dinámica en diseño: formato tabular.

=SI(CONTAR.SI(C$1:C4;C4)>1;0;MAX(E$1:E3)+1)

No será muy bien presentado pero no veo forma de incluirlo dentro de la opción de "campo calculado" sobre la misma tabla dinámica.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Campo Contar Tabla Dinamica

Publicado por Luis Fernando Giraldo (805 intervenciones) el 23/10/2010 04:20:32
No Eduardo no hay necesidad de ordenar, solo colocará el consecutivo cada vez que encuentre un elemento que no exista en los registros anteriores.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar