Excel - PREGUNTA PARA JCS

   
Vista:

PREGUNTA PARA JCS

Publicado por MARIO (4 intervenciones) el 03/04/2012 22:50:09
Buenas noches jcs, gracias por tu ayuda, me ha servido de mucho lo unico que ahora me encuentro con el problema de que yo dispongo de 15 hojas y unicamente me deja buscar en 6 hojas y a la 7º me dice que la formula es demasiado larga, ¿hay alguna manera de simplificar la formula para que me deje buscar en todas?

muchas gracias por todo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

PREGUNTA PARA JCS

Publicado por enrique54 (90 intervenciones) el 04/04/2012 00:12:51
Hola la funcion de si solo acepta hasta 7 condiciones anidadas, lo dice la misma ayuda
asi que hasta ahi llegaste
a menos que los del foro digan lo contrario ysea una mejora para el office 15
saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

PREGUNTA PARA JCS

Publicado por jcs (494 intervenciones) el 04/04/2012 09:23:54
Muy buenas.

Como bien te dice Enrique, en Excel 2003 hay una limitación de 7 funciones anidadas (En Excel 2010 son 64 y en Excel 2007 lo desconozco), por lo que, si tienes el 2003, el planteamiento hecho no nos va a servir.
Para mí, la mejor solución sería hacer una función personalizada. ¿Sabes algo de código VBA?
Otra solución más sencilla sería crear una columna auxiliar (la puedes ocultar), en la que poner:
En B1
=SI(ESERROR(BUSCARV($A15;'1'!$A:$N;2;FALSO));"";BUSCARV($A15;'1'!$A:$N;2;FALSO))
En B2
=SI(ESERROR(BUSCARV($A15;'2'!$A:$N;2;FALSO));"";BUSCARV($A15;'2'!$A:$N;2;FALSO))

En B15
=SI(ESERROR(BUSCARV($A15;'15'!$A:$N;2;FALSO));"";BUSCARV($A15;'15'!$A:$N;2;FALSO))

Si los datos son únicos, o sea, que no se pueden encontrar en más de una página, concatenas los resultados en la celda que quieras:
=SI(B1&B2&B3&B4&B5&B6&B7&B8&B9&B10&B11&B12&B13&B14&B15="";$L15;B1&B2&B3&B4&B5&B6&B7&B8&B9&B10&B11&B12&B13&B14&B15)

Si los datos no son únicos, y lo que tú quieres es que te aparezca la primera solución que encuentre, lo anterior no sirve y habría que hacer otras cosas. De momento, ya me dirás si te vale.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar