Excel - FUNCION =buscar.... ME DA OTRO RESULTADO

   
Vista:

FUNCION =buscar.... ME DA OTRO RESULTADO

Publicado por javier (1 intervención) el 22/05/2013 16:27:45
Tengo esta funcion =BUSCAR(10;H2:H7;B2:B7)

columna H es el promedio de varias notas de un alumno
Columna B es el Nombre d e los alumnos

Alumno PROMEDIO
ALMEYDA Pablo 10
BRITES Marcelo 5
LEZCANO Natalia 4,1
PEREZ Juan 9
VILLALBA Martin 8,6
ZARZA ,,,Hugo 3,8

EL PROMEDIO lo calculo con =PROMEDIO(C2:F2) ciendo la columna c las notas

La columna PROMEDIO son valores calculados con la funcion promedio.


y con la funcion =BUSCAR(10;H2:H7;B2:B7) deseo obtener el que se aya sacado un 10 como promedio, pero no me da como resultado el nombre dle que se saco esa nota, me tira como resultado el ultimo nombre de la columna.

cual es el error?

Pense que se debia por que la columna promedio es calculada, y probe hacer lo mismo, pero con otra columna donde escribi los numeros, y me da resultado erroneo...

la formula esta bien escrita, pero me da otro valor no buscado, cual es mi error?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

FUNCION =buscar.... ME DA OTRO RESULTADO

Publicado por Josean (82 intervenciones) el 22/05/2013 22:49:21
Javier, ¿porqué no pruebas con filtros?
Creo que puede ser una buena solución.
Saludos,
Josean.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

FUNCION =buscar.... ME DA OTRO RESULTADO

Publicado por javier (1 intervención) el 23/05/2013 07:51:46
no... tiene que ser asi, es para un trabajo practico, el orden de los nombres esta bien, de la A asta la Z, lei en algunos foros que debe estar ordenado, y asi esta, y no me funciona
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

FUNCION =buscar.... ME DA OTRO RESULTADO

Publicado por jesus (1 intervención) el 07/11/2014 09:06:50
Hola. me pasaba lo mismo y encontre la solucion o eso creo. resulta que si pones el siguiente ejemplo:
columna1 columna 2
1 A
2 B
3 C
4 D
5 E
Si ahora introduces la funcion buscar , diciendo que busque el número 3 en la culimna1 y que te de la letra de la columna 2. La funcion funciona perfectamente.
ahora bien si la columna1 se presenta de esta forma
5
4
3
2
1
La funcion buscar no encuentra el dato "3" y arroja un resultado erroneo.

Hay 2 soluciones posibles. La primera es ordenar las notas en orden creciente.
Pero si no puedes hacerlo lo que se debe hacer es poner las notas en formato de celdas tipo texto. en ese caso da igual el orden porque la funcion buscar si lo detecta.

Luego o lo pones en formato texto o lo ordenas de menor a mayor.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

FUNCION =buscar.... ME DA OTRO RESULTADO

Publicado por Josean (82 intervenciones) el 03/06/2013 23:02:24
Javier te mando este enlace de youtube, y a ver si te soluciona el problema.

Ya dirás si te ha valido.
Saludos,
Josean.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar