Excel - +SI(...)

   
Vista:

+SI(...)

Publicado por Jnun (1 intervención) el 13/12/2013 22:17:07
Estimados,

Deseo hacer lo siguiente espero que me puedan ayudar:

Lista A
01Homo
03Homo
05Homo
11Homo
02Random
03Random
12Random
06Copo
08Copo
12Copo
16Copo
20Copo

Si selecciono en una celda (ej. A1) cualquier resultado de la 'Lista A', que en la siguiente celda (ej. A2), me aparezca: Homopolimero (si selecciono 01Homo-11Homo), Random (si selecciono 02Random-12Random) o Copolimero (06Copo-20Copo).
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

+SI(...)

Publicado por jcs (494 intervenciones) el 16/12/2013 08:49:42
Muy buenas.

Bueno, hay varias posibilidades. Te digo dos:
1)
En otra hoja (Hoja2) creas la siguiente lista a partir de A1:
Homo Homopolimero
Random Random
Copo Copolimero

En la celda A2 de tu primera hoja pones la siguiente fórmula:
=BUSCARV(EXTRAE(A1;3;6);Hoja2!$A$1:$B$3;2;0)

2)
Sin necesidad de hacer un tabla, en A2 pones:
=SI(EXTRAE(A1;3;6)="Homo";"Homopolimero";SI(EXTRAE(A1;3;6)="Random";"Random";"Copolimero"))

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar