Excel - problemas con BUSCARV

   
Vista:

problemas con BUSCARV

Publicado por Rubby (1 intervención) el 03/03/2014 19:02:24
Por razones de un software de la oficina de impuestos de Bolivia, he cambiado el separador de listas y estoy usando el pipeline (|) Todo bien hasta aquí, todas las funciones corren sin problemas si uso este separador.
El problema:
Tengo una Hoja1 con una tabla de NITs (códigos de identificación tributaria) en las celdas B2:C6, a esta tabla le dí el nombre de Tabla_NITs.
La fila 2 contiene el encabezado
La columna B (B3:B6) tiene los códigos
La columna C (C3:C6) contiene los nombres de las empresas.
En la hoja 2, en un cuadro simple coloco:
En G3 el código que introduce el usuario.
En H3 escribo: =BUSCARV(B3|Tabla_NITs|2|FALSO)

....pero me sale un mensaje de error...


Sin embargo, si en lugar de usar el nombre de tabla, utilizo la referencia a celdas, funciona perfectamente.(en A2:D14) utilizando =BUSCARV(B3|Hoja1!$B$2:$C$1000|2|FALSO)
Si continúo utilizando referencia a tablas, pero cambio el separador de listas a coma o punto y coma, funciona sin problemas...
... tiene algún problema la función BUSCARV al trabajar con el separador pipeline referenciando nombres de rangos o tablas?

Gracias anticipadas por su ayuda!!!
Atte

Rubby Cortéz V.
Santa Cruz - Bolivia
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder