Excel - Formula condicional de Suma

   
Vista:
Imágen de perfil de Edgar

Formula condicional de Suma

Publicado por Edgar zabre52@hotmail.com (3 intervenciones) el 13/03/2014 01:36:22
saludos

es la primera vez que escribo y espero me puedan ayudar con este problema en excel

lo planteo de esta manera

tengo una hoja donde de la Fila D33 hasta la celda LE33 tengo unos valores y estoy realizando una formula que comprueba diferentes criterios lógicos y me arroja un resultado en la fila D34 hasta celda LE34

esta es la formula dela celda CZ33

=SI(Y(CZ33>0,SUMA($D$33:CZ33)>0),SI(Y(CY33>0,SUMA($D$33:CZ33)>CZ33),CZ33,SI(Y(CX33>0,CY33>0),SUMA($D$33:CZ33),SI(CX33>0,CY33+CZ33,SI(Y(CX33<0,CW33<0,CV33<0,CU33<0),SUMA(CX33:CZ33),SUMA($D$33:CZ33))))),0)*-1

el problema esta en la parte donde supongamos que en cada celda tenemos los siguientes valores (las separaciones son de las celdas d33 e33 etc..)

valores de celda 0 0 0 0 0 0 0 -1 -1 -1 -1 2 2 2 2 2 -1 2 2 2 -1 -1 -1 -1 2 2 2 2 2 -1 -1 1 1 1 2 2
resultado de la formula deberia ser el siguiente para cada celda pero no lo hace asi
0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 0 1 2 2 0 0 0 0 0 0 2 2 2 0 0 0 0 1 2 2
por que no sabe como vilver a empezar a sumas cuando se encuentra con un negativo nuevamente yo como se ve en la formula intente decir que si las 5 filas anteriores son menores a 0 realice la suma SI(Y(CX33<0,CW33<0,CV33<0,CU33<0),SUMA(CX33:CZ33)
pero el problema es cuando tengo nuevamente negativos y positivos.

la pregunta es como le digo al excel que cada vez que encuentre un negativo vuelva a realizar una suma desde esa celda hasta que se convierta dicha suma en positivo

espero haberme explicado

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana

Formula condicional de Suma

Publicado por Antoni Masana (264 intervenciones) el 13/03/2014 06:30:09
Si colocas esta ristra de números en la fila 9 desde la A hasta la AJ

0 0 0 0 0 0 0 -1 -1 -1 -1 2 2 2 2 2 -1 2 2 2 -1 -1 -1 -1 2 2 2 2 2 -1 -1 1 1 1 2 2

Y pones estas dos formulas

=SUMAR.SI(A9:AJ9;"<0")
=SUMAR.SI(A9:AJ9;">0")

La primera suma los positivos y la segunda los negativos cuyos resultados son 22 y -11 respectivamente.

En tu ejemplo para sumar los positivos la formula seria esta:

=SUMAR.SI(D33:LE33;">0")

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Edgar

Formula condicional de Suma

Publicado por Edgar (3 intervenciones) el 14/03/2014 16:34:59
si estoy de acuerdo con lo mecionado pero creo que no me he dado a entender no se trata de sumar solo los negativos o postivos se trata de que conforme vayya avanzando en cada celda cuando encuentre que el valos de la celda a sumar sea negativo comience desde cero a partir de esa celda
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar