Excel - Ayuda con Formula de Dividendos

   
Vista:
Imágen de perfil de Edgar

Ayuda con Formula de Dividendos

Publicado por Edgar zabre52@hotmail.com (3 intervenciones) el 13/03/2014 01:46:43
saludos

es la primera vez que escribo y espero me puedan ayudar con este problema en excel

lo planteo de esta manera

tengo una hoja donde de la Fila D33 hasta la celda LE33 tengo unos valores y estoy realizando una formula que comprueba diferentes criterios lógicos y me arroja un resultado en la fila D34 hasta celda LE34

esta es la formula dela celda CZ33

=SI(Y(CZ33>0,SUMA($D$33:CZ33)>0),SI(Y(CY33>0,SUMA($D$33:CZ33)>CZ33),CZ33,SI(Y(CX33>0,CY33>0),SUMA($D$33:CZ33),SI(CX33>0,CY33+CZ33,SI(Y(CX33<0,CW33<0,CV33<0,CU33<0),SUMA(CX33:CZ33),SUMA($D$33:CZ33))))),0)*-1

el problema esta en la parte donde supongamos que en cada celda tenemos los siguientes valores (las separaciones son de las celdas d33 e33 etc..)

valores de celda 0 0 0 0 0 0 0 -1 -1 -1 -1 2 2 2 2 2 -1 2 2 2 -1 -1 -1 -1 2 2 2 2 2 -1 -1 1 1 1 2 2
resultado de la formula deberia ser el siguiente para cada celda pero no lo hace asi
0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 0 1 2 2 0 0 0 0 0 0 2 2 2 0 0 0 0 1 2 2
por que no sabe como vilver a empezar a sumas cuando se encuentra con un negativo nuevamente yo como se ve en la formula intente decir que si las 5 filas anteriores son menores a 0 realice la suma SI(Y(CX33<0,CW33<0,CV33<0,CU33<0),SUMA(CX33:CZ33)
pero el problema es cuando tengo nuevamente negativos y positivos.

la pregunta es como le digo al excel que cada vez que encuentre un negativo vuelva a realizar una suma desde esa celda hasta que se convierta dicha suma en positivo

espero haberme explicado

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder