Excel - Sumar valores unicos

   
Vista:

Sumar valores unicos

Publicado por Manuel (10 intervenciones) el 08/04/2016 21:07:46
Buenas tarde, estoy tratando de hacer una macro en vb que me haga lo siguiente:
Tengo una hoja llamada DATOS y otra llamada CLIENTES
En la hoja DATOS tengo una tabla con estos encabezados PROVEEDOR - FECHA - TOTAL
las columnas son D E F respectivamente, en D tengo los nombres de proveedores en E las fechas y en F el total.
Los mismos datos los tengo en la hoja CLIENTES y ademas tengo PROVEEDOR - TOTALES en la columna H
y en la I los encabezados estan en la fila 6 y los datos en la fila 7.
En la hoja CLIENTES
Para hayar los datos de TOTAL tengo esta formula: =SI.ERROR(BUSCARV($C8;DATOS!$C$7:$F$2000;F$4;FALSO);"")
y en la columna I tengo esta otra formula
=SUMAR.SI(DATOS!$D$7:$F$2000;"ACANA";DATOS!$F$7:$F$2000)
Las dos formulas me funcionan estupendamente pero yo lo que necesito es que en vez de las formulas sea una
macro que me haga lo mismo en VB
En C de la hoja DATOS tengo los numeros de cada nombre y en F4 los valores. Espero haberme explicado bien
y si no es así pueden solicitarme cualquier dato que necesiten. Un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com

Sumar valores unicos

Publicado por wordexperto.com (496 intervenciones) el 08/04/2016 21:28:11
Hola Manuel:
Yo, en vez de fórmulas y macros, para los informes usaría Tablas dinámicas. Se crearon para esto.
http://wordexperto.com/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Andres Leonardo

Sumar valores unicos

Publicado por Andres Leonardo (490 intervenciones) el 10/04/2016 01:08:01
Yo cuando necesito rapido

cuento cuantas veces se repiten los valores
le hago una fila ... ... filtro por los iguales a 1 y Suma

Listo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar