Excel - Mje a JoseLuis y JCS

   
Vista:

Mje a JoseLuis y JCS

Publicado por pepe (3 intervenciones) el 23/11/2007 05:20:57
hola es sobre esto otra vez

En A1 ="?"
En B1 ="?"
En C1, =SI(O(A1="?";B1="?");"?";A1+B1)

lo que pasa es que esta bien,

pero yo crei que al borrar el dato no se borraria el ? ,, supongo que era sobreescribir en la celda donde habia ? , un nro ,
y si borrabas el nro por un error que cometias , el ? estaba alli fijo,

bueno esto lo vi en una aplicacion, pero no pude guardar el archivo porq no me dejaron ,
porq era un trabajo del instituto y ahora para unos examenes he visto que esta planteado como pregunta, alguna idea amigos, haber si nos ayudan los amigos Abraham y JuanC

saludos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Mje a JoseLuis y JCS

Publicado por José Luis (700 intervenciones) el 23/11/2007 14:30:18
Prueba con esta macro colocada en el módulo de la hoja donde haces la operación.

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If [A1].Value = Empty Or Not IsNumeric([A1].Value) Then
[A1].Value = "?"
End If

If [B1].Value = Empty Or Not IsNumeric([B1].Value) Then
[B1].Value = "?"
End If
End Sub

Debes mantener la fórmula anterior en C1.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar