Excel - consulta relacionar datos

   
Vista:

consulta relacionar datos

Publicado por diego (2 intervenciones) el 12/02/2008 23:14:45
Mi consulta es la siguiente,, primero observemos las 2 hojas que tengo...:
Hoja1:
1-pablo
2-eric
3-juan
4-malaver

hoja2:
1-ingles
1-frances
1-aleman
2-español
3-español
4-español

bien ahora necesito una formula que me traiga lo siguiente (resaltado con %%):
1 - pablo - %ingles, frances,aleman%
2 - eric - %español%
3 - juan - %español%
4 - malaver - %español%

estoy totalmente perdido y desorientado, tambien abombado por tantas cosas que he probado sin ningun resultado,, recuro a ustedes a ver que se les ocurree!!.. desde ya mil gracias por cualquier consejo brindado. salu2.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:consulta relacionar datos

Publicado por jcs (494 intervenciones) el 13/02/2008 14:30:26
Muy buenas,

a falta de una mejor opción, te doy una posibilidad un tanto enrevesada,

suponiendo que las claves las tengas en la columna A y los nombres en la B de la hoja1,
suponiendo que las claves las tengas en la columna A y los idiomas en la B de la hoja2,

En la hoja1 puedes poner lo siguiente:
C1
=CONCATENAR("%";J2;K2;L2;M2;"%")
D1
=COINCIDIR(A1;Hoja2!A$1:A$6;0)
E1
=COINCIDIR(A1;Hoja2!A$1:A$6;1)
F1
=DIRECCION(D1;2;;;"Hoja2")
G1
=SI(D1+1<=E1;DIRECCION(D1+1;2;;;"Hoja2");"")
H1
=SI(D1+2<=E1;DIRECCION(D1+2;2;;;"Hoja2");"")
I1
=SI(D1+2<=E1;DIRECCION(D1+2;2;;;"Hoja2");"")
J1
=INDIRECTO(F1)
K1
=SI(ESERR(INDIRECTO(G1));"";", "&INDIRECTO(G1))
L1
=SI(ESERR(INDIRECTO(H1));"";", "&INDIRECTO(H1))
M1
=SI(ESERR(INDIRECTO(I1));"";", "&INDIRECTO(I1))

Si no te funciona con los ; sustitúyelos por ,

De todas formas, yo ya lo tengo hecho, así que si quieres te lo mando

Espero que te sirva.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:consulta relacionar datos

Publicado por Marvin Osorio (368 intervenciones) el 13/02/2008 23:23:42
Pues esta bien la solucion de jcs, ya que para darle solución a este problema deben crearse otras columnas,

Ahora, aunque se pude hacer mediante una macro... pero llevaría tiempo.

Salu2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:consulta relacionar datos

Publicado por Roberto (1 intervención) el 19/07/2008 19:04:32
Diego si ya sabes como hacerlo me gustaría que me brindes la información por que estoy con la misma dudas y lo requiero para un estudio de muestreo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:consulta relacionar datos

Publicado por Diego (2 intervenciones) el 19/07/2008 19:24:30
Roberto, no hay manera de realizar dicha operacion. fue hace mucho y no recuerdo como lo resolvi, pero estoy casi seguro que lo termine haciendo en Visual Fox Pro (Con acceso a datos) y luego el resultado la base de datos de vfp la importe a Excel, Exitos! salu2.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar