Excel - funcion promedio por favor ayuda

   
Vista:

funcion promedio por favor ayuda

Publicado por emmanuel de la mata (1 intervención) el 27/05/2008 19:46:13
mi pregunta es la siguiente :tengo una columna de 8000 celdas con datos y necesito obtener promedios de cuatro en cuatro , me explico , quiero que me promedie las primeras cuatro celdas y me de el valor , y luego me haga el promedio de las cuatro celdas que siguen y así sucesivamente hasta obtener todos los promedios, son muchos los datos y es de suma importancia aprender a hacer esto porque es para realizar un trabajo de tesis . probé hacerlo con la función promedio pero no logro obtener los resultados que quiero porque me promedia 4 celdas pero luego la función se corre cada 1 celda y yo quiero que la función se corra cada cuatro celdas.. Por favor espero sus respuestas.
explicacion mas detallada :
datos
1
1 promedio 1
1
1
2
2 promedio2
2
2
3
3 promedio 3
3
3
4
4 promedio 4
4
4
yo necesito extraer esos promedios para luego trabajar sobre ellos , con la funcion promedio y indicandole que promedie las cuatro primera celdas me da bien el resultado pero cuando corro la funcion hacia abajo me empieza a promedia pero corriendose un solo lugar en el valor de promedio es decir me promedia primero las celdas A1 A2 A3 A4 LUEGO A2 A3 A4 A5 LUEGO A3 A4 A5 A6 A7 Y ASI SUCESIVAMENTE YO QUIERO QUE SEA ASI: PROMEDIE A1 A2 A3 A4 LUEGO A5 A6 A7 A8 LUEGO A9 A10 A11 A12 Y ASI SUCESIVAMENTE .. POR FAVOR ESPERO SU RESPUESTAS Y MUCHAS GRACIAS POR TODO
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:funcion promedio por favor ayuda

Publicado por Luis Fernando (805 intervenciones) el 27/05/2008 20:38:56
Supongamos que los datos estan en la columna "A" de la fila 1 a 8000, usa entonces en la celda B1 lo siguiente:

=SI(FILA(A4)/4=ENTERO(FILA(A4)/4);PROMEDIO(A1:A4);0)

con ello lo que se esta es identificando filas divisibles por 4 para ahi si calcular el promedio, de lo contrario colocando un CERO

de ahi la copias a las demas filas de la columna "B"

Cordial saludo desde Pereira Colombia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar