Excel - MACRO PARA REPETICION

   
Vista:

MACRO PARA REPETICION

Publicado por Marco (1 intervención) el 18/06/2008 19:00:21
Saludos!!!, quiero hacer una macro q me haga la repeticion de un numero de referencia, es decir, tengo 2 columnas en excel

COL1 COL2

261120
1254
9565
261120
1254
1538
2041
9556
9565
261058
1302
9556
261058
141
334
1254
1302
9556
9565

y necesito q me ponga en la COL1 los numeros q tienen 6 digitos de la columna 2, y q me los repita pero solo en los numeros q tienen menos de los 6 digitos, es decir:

COL1 COL2

261120 ' (6 digitos)
261120 1254 ' (4 digitos)
261120 9565 ' (4 digitos)
261120 ' (6 digitos)
261120 1254 ' (4 digitos)
261120 1538 ......
261120 2041
261120 9556
261120 9565
261058
261058 1302
261058 9556
261058
261058 141
261058 334
261058 1254
261058 1302
261058 9556
261058 9565

Si alguien sabe como hacerle, les pido de favor q me digan como, mi correo es marcoman9@hotmail.com

GRACIAS!!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:MACRO PARA REPETICION

Publicado por weirdmix (4 intervenciones) el 18/06/2008 23:24:17
para hacer algo asi necesitas de un programador....
echame un mail si te interesa q te ayude...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:MACRO PARA REPETICION

Publicado por jcs (494 intervenciones) el 19/06/2008 09:01:53
Muy buenas,

si te he entendido bien, creo que bastaría con poner a partir de A2 los siguiente:

=SI(LARGO(B2)=6;B2;A1)

Espero que te sirva.

Un saluod. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:MACRO PARA REPETICION

Publicado por Jack (1 intervención) el 20/08/2008 17:57:01
Hola que tal
Alguien me puede ayudar,necesito qu en unrango de celdas (A1 hasta A10) no se repitan los numeros que escriba, si ya puse 2 cuando intente volverlo a poner que me mande un mensaje.

Gracias por su ayuda.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar