FoxPro/Visual FoxPro - problema con combobox

   
Vista:

problema con combobox

Publicado por EDUARDO (3 intervenciones) el 08/05/2011 02:35:28
tengo un combobox ,el cual esta en una hoja de un pageframe .y me muestra secciones (contaduria,expedicion,etc )
en el rowsource del mismo tengo: 'secciones.nombre,codigo' ,en el rowsourcetype tengo 'fields'
el problema que tengo es que .elijo un empleado para modificar sus datos y en el combobox no me muestra el nombre de su seccion .
en el activate de la hoja del form puse un brow de la tabla empleados ,para ver que la tabla este posicionada en el empleado elegido ,y un brow de la tabla secciones ,para ver que este en el registro que coincide con el codigo de seccion del empleado (ambas tablas se relacionan por el codigo).pero,aunque las tablas esten posicionadas en los registros correctos , me muestra el valor del combo vacio .desde ya gracias por la ayuda
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

problema con combobox

Publicado por Juan Manuel Cruz juanmcruz@hotmail.com (508 intervenciones) el 09/05/2011 18:29:26
Si ya descartaste que sea el BoundColumn, mira que tu combobox, en la hoja de propiedades en diseño, tenga VALUE espacios vacíos, porque si tiene por defecto 0 (cero, valor numérico) puede comportarse de manera rara, intentando mirar por el índice del elemento, y no por valor del campo clave.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problema con combobox

Publicado por xx (378 intervenciones) el 09/05/2011 15:18:14
Busca info sobre el metodo REQUERY() del combo quizas sea tu solución

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problema con combobox

Publicado por pepebr (1 intervención) el 15/08/2012 18:25:12
Eduardo pudiste solucionar el problema? porque a mi me pasa lo mismo y no encuentro donde está el error, ya intente con el requery en varias partes del formulario. Lo que noté es que si en el data enviroment del formulario la vista del combobox esté en .f. el -nodataonload- funciona bien, pero si se pone en .t. falla. No sabes si hay alguna propiedad a modificar ? ya que el rowsource como el controlsource y estan correctos. Gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar