Framework .NET - Problema Usercontrol en 1.1 y 2.0

   
Vista:

Problema Usercontrol en 1.1 y 2.0

Publicado por Nacho (2 intervenciones) el 26/09/2008 10:29:16
Hola a todos, tengo un UserControl DLL desarrollado en VS2003. Este UserControl está embebido por medio de un objeto <OBJECT> en una página ASPX.

Los PCs cliente, llaman a la página ASPX que muestra el UserControl y todo funcionaba perfectamente. Estos PCs tienen instalada la versión 1.1 del FW .NET.

Ahora han comprado otros PCs que tienen instalada la versión 2.0 del FW .NET, Y NO FUNCIONA, carga la página ASPX pero ni llega a cargar el control. No muestra ningún mensaje de error, pero no carga (aparece un cuadro blanco en su lugar).

¿No eran compatibles las versiones del FW hacia atrás?
¿Qué puedo hacer? No puedo compilar el UserControl DLL en VS2005, porque hay PCs que sólo tienen la 1.1

Gracias de antemano,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema Usercontrol en 1.1 y 2.0

Publicado por Javier Suero (3 intervenciones) el 26/09/2008 14:18:05
Hola, Nacho,

los ensamblados apuntan a una versión concreta del framework. .Net está pensado para que varias versiones del Framework puedan convivir. Así que los de la versión 2 se pueden instalar además la 1. O compilas con la dos y los de la 1 se instalan la 2....

Un saludo, Javier Suero.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema Usercontrol en 1.1 y 2.0

Publicado por Nacho (2 intervenciones) el 26/09/2008 18:32:52
Gracias Javier, pero no lo entiendo ¿tengo que tener 2 DLLs?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar