GeneXus - Error al compilar Reporte en Genexus

   
Vista:

Error al compilar Reporte en Genexus

Publicado por agrauer (14 intervenciones) el 08/08/2009 17:05:51
Buenas,

Mi problema es el siguiente.

Estoy generando una aplicacion en .Net, interface Win, en genexus 9.0

Todo me compila perfecto salvo un reporte.
El reporte se llama Etiquetas, y no tiene nada dinamico. Simplemento un texto.

El error que me sale es el siguiente:

Task: oEtiquetas Status: Failed
Compiling oEtiquetas
gxexec "C:Archivos de programaARTechGeneXusDoar PostDATA002ldoEtiquetas.cs" -r:GxBaseBuilder.dll -arg:csc="C:WINDOWSMicrosoft.NetFrameworkv3.5csc.exe" -arg:mdlpath="C:Archivos de programaARTechGeneXusDoar PostDATA002"
Could not find file "C:Archivos de programaARTechGeneXusDoar PostDATA002ldoEtiquetas.cs".

que puede ser?
gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Error al compilar Reporte en Genexus

Publicado por agrauer (14 intervenciones) el 08/08/2009 21:46:30
Ya pude solucionar eso. simplemente le cambie el Call Protocol de HTTP a internal

Ahora tengo un nuevo problema:
Tengo una transaccion en la que ingreso distintos datos sobre un pedido que hace un cliente.

Lo que yo necesito es, que inmediatamente despues de confirmar los datos, se cree un reporte con esos mismos datos en un archivo pdf.
Quiero que este archivo salga en la pantalla y ahi el usuario puedra elegir si lo imprime o lo guarda.

Para esto, en las reglas de la transaccion puse:
Call(REtiquetas) on AfterComplete;

Pero al correr el programa me salta el siguiente error:

"An unhandled xception has ocurred in your application. If you clik Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will be shut down immediately.

com.ms.vjsharp.lang.ThrowableWrapper: Failed to load type GeneXus. Programs. o etiquetas, assembly: oetiquetas."

Que debo hacer?
En las opciones del reporte que debo poner en Main Program, en Call Protocol y demas items.

Les recuerdo que estoy trabajando con Genexus 9.0 en XP. Y usando .Net e interface Win

Muchas Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Patricio Ojeda V

RE:Error al compilar Reporte en Genexus

Publicado por Patricio Ojeda V (454 intervenciones) el 13/08/2009 00:48:27
agrauer,

Lo de definir el reporte como main program y luego seleccionar el protocolo es para aplicaciones Web... no para Win...

Quizás por eso tienes ese error,

Saludos

Patricio Ojeda V
Analista Senior GeneXus
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error al compilar Reporte en Genexus

Publicado por juan carlos cauich ruiz juan.cauich@yucatan.gob.mx (1 intervención) el 18/05/2011 16:06:42
Hola, estoy aprendiendo a programar en Genexus EV 1 upgrade 2.5 y pues tengo el siguiente problema:

Genere un KB en c# con mysql y cuando ejecuto el build para generar los compilados, se ejecuta perfecto, solo que antes de lanzar el explorador el ultimo mensaje que me salió es:
========== Execution started ==========
error: System.ComponentModel.Win32Exception: No se ha encontrado la aplicación
en System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
en System.Diagnostics.Process.Start()
en Artech.Packages.Genexus.BL.Services.RunServices.RunBase.BrowseUrl(String url)
en Artech.Packages.Genexus.BL.Services.RunServices.RunBase.ExecuteCommand(IDictionary`2 tokens, String command, Boolean synchro, Boolean printCmd)
en Artech.Packages.Genexus.BL.Services.RunServices.RunDotNet.Execute(KBModel model, EntityKey objKey)
Execution Failed

ya me dijeronm que con solo abrir el explorador funciona, pero no es cierto, no funciona. ¿Alguien a tenido este mensaje ???

gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error al compilar Reporte en Genexus

Publicado por enrique (39 intervenciones) el 25/06/2015 01:15:39
Hola Patricio! tengo un problema similar :
estoy trabajando con la version trial de Gx Evo2 y tengo el siguiente problema:
cree un objetode tipo Procedimiento, no le agrego codigo, lo ejecuto y me sale el siguiente problema:

========== Execution started ==========
"C:\Models\kb_enrique2\CSharpModel\web\bin\proc_busca_usuario.exe"
error: System.ComponentModel.Win32Exception: El sistema no puede encontrar el archivo especificado
en System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
en System.Diagnostics.Process.Start()
en Artech.Genexus.Common.Run.RunBase.ExecuteCommand(IDictionary`2 tokens, String command, Boolean synchro, Boolean printCmd)
en Artech.Genexus.Common.Run.RunBase.ExecuteCommand(IDictionary`2 tokens, String command, Boolean synchro)
en Artech.Packages.Genexus.BL.Services.RunServices.RunDotNet.Execute(KBModel model, EntityKey objKey, String execParams)
Execution Failed
Run With This Only Failed


desde ya muchas gracias!
un saludo cordial!
enrique
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar