GeneXus - Llevar a produccion

   
Vista:

Llevar a produccion

Publicado por Ivan (24 intervenciones) el 14/12/2009 16:38:33
Buenos dias Charly!!,,, pues me has ayudado mucho!!! ya quedo lo de la pagina de inicio, mejor dicho ya entendi como va esa parte, el problema era que no entendia como iba, pero ya me has aclarado mas el panorama, pero que crees, tengo otra molestia, otra duda, con forme he ido avanzando en la puesta en produccion, me han salido muchas dudas (ya que es mi primer sistema), pero poco a poco las he ido resolviendo, ya llegue a la parte del archivo WEB.CONFIG, tu has modificado alguna vez este archivo?? lei un poco y se trata de el archivo que tiene el nombre del equipo, base de datos, usuario, contrae;;a,. etc etc, mi duda es, sobre esta linea, no se que significa, mira te la escribo haber si tu me podrias orientar un poco sobre esta linea ya que cuando corro el sitio web en el browser me marca un error en la linea '4' osea esta:

<sectionGroup name="languages" type="System.Configuration.NameValueSectionHandler">

(es una sola linea en el .TXT(4 ta LINEA))
TU SABES QUE SIGNIFICA??? SE QUE ES DE LA SPROPIEDADES DEL MODELO DE GENEXUS (.NET), PERO YA BUSQUE TODA LA SEMANA PASADA JAJAJA, Y NADA, Y NO PASO DE ESTE ERROR, de antemano como siempre te agradesco por toda la ayuda, y lo de darme la solucion, yo decia que me dieras una idea, por que a veces cuando las personas no sabemos mucho como en mi caso, no nos quieren contestar en este foro o en otros, o te contestan al aventon y te confunden mas. A veces se nos olvida como comenzamos todos, y que en realidad no sabemos nada, es solo que cada dia comenzamos con mas experiencia, te agradesco mucho Charly, y bueno espero tu respuesta me sera de mucha ayuda (como lo han sido todas las respuestas) cuidate mucho y si no nos hablamos hasta el otro a;o., Felices fiestas!!!

bonita navidad, y feliz a;o nuevo, gracias de nueva cuenta, chao!

Tambien te escribo todo mi WEB.CONFIG POR SI LAS DUDAS, VALE???
SALUDOS....


<configuration>
<configSections>
<section name="log4net" type="log4net.Config.Log4NetConfigurationSectionHandler, log4net" />
<sectionGroup name="languages" type="System.Configuration.NameValueSectionHandler">
<section name="Spanish" type="System.Configuration.SingleTagSectionHandler" />
</sectionGroup>
</configSections>
<appSettings>
<add key="AppMainNamespace" value="GeneXus.Programs" />
<add key="DataStore1" value="Default" />
<add key="DataStore-Count" value="1" />
<add key="Connection-Default-DBMS" value="sqlserver" />
<add key="Connection-Default-Port" value="" />
<add key="Connection-Default-LockTimeout" value="0" />
<add key="Connection-Default-LockRetryCount" value="10" />
<add key="Connection-Default-Datasource" value="ENDTOEND10" />
<add key="Connection-Default-User" value="82sPNmMP8O3TlpdEZk1r8E==" />
<add key="Connection-Default-Password" value="82sPNmMP8O3TlpdEZk1r8E==" />
<add key="Connection-Default-DB" value="Factura" />
<add key="Connection-Default-Opts" value=";Integrated Security=yes;" />
<add key="Connection-Default-TrnInt" value="1" />
<add key="DateFormat" value="DMY" />
<add key="YearLimit" value="1940" />
<add key="TimeAmPmFormat" value="24" />
<add key="VER_STAMP" value="20091123.200532" />
<add key="CS_BLOB_PATH" value="" />
<add key="TMPMEDIA_DIR" value="" />
<add key="LOGIN_AS_USERID" value="0" />
<add key="LANGUAGE" value="spa" />
<add key="LANG_NAME" value="Spanish" />
<add key="DECIMAL_POINT" value="." />
<add key="DATE_FMT" value="SPA" />
<add key="Culture" value="es-ES" />
<add key="CACHING" value="0" />
<!--Almost Never-->
<add key="CACHE_TTL_3" value="-1" />
<!--Hardly Ever-->
<add key="CACHE_TTL_2" value="600" />
<!--Time to Time-->
<add key="CACHE_TTL_1" value="60" />
<!--Pretty Often-->
<add key="CACHE_TTL_0" value="0" />
<add key="CACHE_STORAGE_SIZE" value="0" />
<add key="CONN_TIMEOUT" value="30" />
<add key="MAX_CURSOR" value="100" />
<add key="ISOLATION_LEVEL" value="CR" />
<add key="STATIC_CONTENT" value="" />
<add key="PROVIDER" value="Microsoft" />
<add key="EVENT_BEFORE_COMMIT" value="" />
<add key="EVENT_AFTER_COMMIT" value="" />
<add key="EVENT_BEFORE_ROLLBACK" value="" />
<add key="EVENT_AFTER_ROLLBACK" value="" />
<add key="EVENT_BEFORE_CONNECT" value="" />
<add key="EVENT_AFTER_CONNECT" value="" />
<add key="COMPRESS_HTML" value="1" />
</appSettings>
<languages>
<Spanish code="spa" time_fmt="24" decimal_point="." thousand_sep="," date_fmt="DMY" culture="es-ES" />
</languages>
<log4net threshold="OFF">
<appender name="RollingFile" type="log4net.Appender.RollingFileAppender">
<file value="client.log" />
<appendToFile value="true" />
<maximumFileSize value="9000KB" />
<maxSizeRollBackups value="4" />
<layout type="log4net.Layout.PatternLayout">
<conversionPattern value="%d{HH:mm:ss,fff} [%t] %-5p %c{1} [%x] - %m%n" />
</layout>
</appender>
<appender name="ASPNetTraceAppender" type="log4net.Appender.ASPNetTraceAppender">
<layout type="log4net.Layout.PatternLayout">
<conversionPattern value="%d{HH:mm:ss,fff} [%t] %-5p %c{1} [%x] - %m%n" />
</layout>
</appender>
<appender name="EventLogAppender" type="log4net.Appender.EventLogAppender">
<layout type="log4net.Layout.PatternLayout">
<conversionPattern value="%d [%t] %-5p %c{1} [%x] - %m%n" />
</layout>
</appender>
<root>
<level value="DEBUG" />
<appender-ref ref="RollingFile" />
</root>
</log4net>
<system.web>
<trace enabled="false" />
<httpHandlers>
<add verb="*" path="*.aspx" type="GeneXus.HttpHandlerFactory.HandlerFactory,gxclasses" />
</httpHandlers>
</system.web>
</configuration>
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Llevar a produccion

Publicado por Chaly (54 intervenciones) el 16/12/2009 03:04:52
Ivan:

Haber, varias cositas:

estas con Sql server?
Transcribeme el error que te sale en el browser, debio generar algun codigo de error.
Como te estas conectando a la BD, ADO, DataSource, etc.

de principio dame esos datos.

Chaly
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Patricio Ojeda V

RE:Llevar a produccion

Publicado por Patricio Ojeda V (454 intervenciones) el 17/12/2009 17:11:50
Ivan,

Tal como se hace en el Gx 9... te recomendaria en el Gx X tener 2 enviroment definidos... el primero para desarrollo con los datos de tu equipo... y el segundo para produccion con los datos del servidor donde instalaras la aplicaion...

De hecho si no haces lo anteriormente descrito... mas adelante cuando desees hacer alguna actualizacion de tu aplicacion en el servidor... se te va a hacer muy complicado hacer eso, pues no vas a saber que cambios "concretamente" haz hecho entre la primera version instalada vs la ultima...

Saludos y suerte,

Patricio Ojeda V
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Llevar a produccion

Publicado por jorgeaca (2 intervenciones) el 21/04/2010 16:13:11
hola mira lo que pasa es que yo tengo el mismo error y nolo he podido solucionar tengo una peque;a aplicacion en genexus 10 compilada en sql2008 y .net pero no he podido ponerla a funcionar ya que el erroro es igal que el tuyo me gustaria que me indiques como lo has solucionado y si depronto puedes mandarme tu correo de hotmail para estar en contacto con tigo.
gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar