HTML - Problema Hipervinculo

   
Vista:

Problema Hipervinculo

Publicado por Cristian (38 intervenciones) el 29/09/2011 23:08:39
Hola a todos..
Tengo el siguiente problema: estoy maquetando una cabecera, y funciona bien pero al momento de hacer el hipervinculo en una imagen, texto o lo que sea cuendo refresco el browser se me mueve toda la pagina, cuando le saco el hipervinculo me lo muestra correctamente ya no se que hacer.. aca dejo algo del codigo simple:

<div style="height: 40px">
<div style="width:78px; float:left; height: 40px;">
<img alt="" border="0" height="30" src="image/clima.gif" width="26">
</div>
<div style="width:73px; float:right;height: 40px;">

</div>
</div>


pero si hago esto fue la maquetacion:

<div style="height: 40px">
<div style="width:78px; float:left; height: 40px;">
<a href="index2.php"><img alt="" border="0" height="30" src="image/clima.gif" width="26"></a>
</div>
<div style="width:73px; float:right;height: 40px;">

</div>
</div>

Espero me puedan ayudar..
Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Problema Hipervinculo

Publicado por xve (1178 intervenciones) el 30/09/2011 08:06:49
Hola Cristian, no se muy bien que te puede estar pasando, pero he cogido tu código y lo he puesto en una pagina html y se ven igual los dos códigos que has mostrado....
No se si tienes algo que ver el resto de código de la pagina, pero esos códigos que muestras, hacen lo mismo.
Revisa que no tengas un estilo en a del href que te de grosor, o algo por el estilo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema Hipervinculo

Publicado por Cristian (38 intervenciones) el 03/10/2011 15:47:54
Hola XVE... gracias por contestar... mira aca te paso la cebecera entera...

<div style="width:983px;">
<div class="contenedor" style="height: 110px" >
<div style="width: 305px;float:left;height: 120px; ">
<a href="index.php"> <img src="image/logo2.png" border="0" alt="">
</div>
<div style="width: 366px; float:left;height: 120px;">
<div style="height: 25px">

</div>
<div style="height: 25px">

</div>

<div style="height: 40px">
<div style="width:130px; float:left; height: 40px; text-align:right; padding-right:10px;">

<img alt="" border="0" height="30" src="image/clima.gif" width="26">
<label style=" font-family:Arial, Helvetica, sans-serif;font-size:10px;">Todo el</label><label style="font-family:Arial, Helvetica, sans-serif;color:#FF6600;font-size:12px;"> CLIMA</label>
</div>
<div style="width:202px; float:right;height: 40px; padding-left:8px;">

</div>

</div>
<div>

</div>
</div>

</div>
</div>

CUANDO HAGO UN HIPERVINCULO EN EL CLIMA AHI SE MA VA PARA CUALQUIER LADO...

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema Hipervinculo

Publicado por Web-Freelance (50 intervenciones) el 03/10/2011 17:33:31
Hola, veo un error claro:

1
<a href="index.php"> <img src="image/logo2.png" border="0" alt="">


Después de esto te falta cerrar </a> después de la imagen. Esto puede hacer que al crear otro link te desmorone la web. Además de estar linkeando todo el contenido erróneamente.

Si esto no funciona, muéstranos el CSS para ver que tienes.

Saludos,
Web-Freelance - Aprende facilmente a crear una web.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema Hipervinculo

Publicado por Cristia (38 intervenciones) el 03/10/2011 18:18:27
Hola...
Ante todo gracias por responder. Mira ni bien deje el post me di cuenta que se ve me he equivocado y borre el cierre ese qu eme indicas... </a>. Cosas que a uno lo vuelven loco.

Y si era eso...

Un saludo y gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar