LabView - Despliegue de señales en Labview, a traves de USB

   
Vista:

Despliegue de señales en Labview, a traves de USB

Publicado por Alberto Herrera (4 intervenciones) el 17/03/2012 21:14:13
Estoy programando en MicroC un PIC18F2550 para comunicarme datos con Labview mediante el puerto USB, y después graficarlos.

Ya he creado el driver para que mi dispositivo lo controle LABVIEW, usando driver wizard, y Labview reconoce mi dispositivo y puedo enviar información al PIC pero cuando trato de recibir información me sale un mensaje de error dentro de labview:

mensaje de error (error-1073807299 se produjo a las VISA USB CONTROL OUT)

Razón posible:
VISA:(Hex 0xBFFF003D) Invalid buffer mask specified.


He encontrado que talvez tengo que cambiar los endpoint descriptors y lo hice sin ningun resultado.

Antes de generar el driver de mi dispositivo para Labview; del PIC se comunicaba de forma correcta de entrada como de salida, con la herramienta HID Terminal de MicroC pero no lo hace igual con labview.

Necesito ayuda sobre este tema; pues mi busqueda en todos los foros de temas similares no me ha dado ningun resultado, agradeceria cualquier ayuda o idea por pequeña que sea.

Saludos Cordiales.

Alberto Herrero
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Despliegue de señales en Labview, a traves de USB

Publicado por eZ (195 intervenciones) el 10/08/2012 16:36:31
El error parece muy generico, he trabajado con proyectos similares, si deseas enviame un email con el codigo en LabVIEW y le puedo dar una revisada... indicame tu mail y yo te mando ahi el mio
Saludos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Despliegue de señales en Labview, a traves de USB

Publicado por Jairo Rivero Jairicinho@gmail.com (1 intervención) el 26/03/2013 15:51:17
Hola eZ, yo también tengo un problema parecido.

Necesito comunicarme con un sintetizador de frecuencia ( HMC833LP6GE FRACTIONAL-N PLL)
a través de LabView, y me da un error al intentar enviarle la petición de lectura mismamente ( 0 0 0 ) .
Me da error al enviarle cualquier comando. El programa en LabView lo descargé de uno de los foros de electrónica al comprobar viendo sus foros que necesitaba los controles VISA USB control IN y VISA USB control OUT.

Si me pudiera enviar su correo para poder enviarle mi Vi de LabView y comprobar si tiene algún fallo se lo agradecería enormemente.

Muchas gracias.
Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Despliegue de señales en Labview, a traves de USB

Publicado por Victor Trejo victortrejo93@hotmail.com (1 intervención) el 05/07/2014 00:38:07
Buen dia Alberto me interesa saber sobre tu proyecto y tratar de implementar algo parecido no se si sea posible que me envies la informacion de tu codigo para el pic y labview o de donde sacaste la informacion ya que no logro encontrar una fuente para poder hacer mi proyecto te lo agradeceria mucho mi correo es victortrejo93@hotmail.com


Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar