LabView - LabView Ni OPC Server y Logo OBA7 de Siemens.

   
Vista:

LabView Ni OPC Server y Logo OBA7 de Siemens.

Publicado por Alex (1 intervención) el 22/06/2012 23:18:31
Buenas y gracias a todos de antemano.

En el instituto estamos trabajando con el software LabView y el plc de siemens LOGO OBA7. Tenemos mas o menos dominado el labview, pero el NI OPC Server se nos resiste. No logramos hacer que el "OPC quick client" se comunique con el LOGO OBA7.

Hemos provado creando el canal con dos drivers diferentes, (Siemens S7200 y Siemens TCP/IP Ethernet), en 'Network adapter:' hemos puesto el adaptador de red inalambrica.
Despues de crear el canal hemos creado un "device". En device model hemos puesto el del S7200 (ya que para conectar el wincc sistema de scada de siemens o el TIA Portal con el Logo OBA7 se usa el driver de este, yo lo he logrado con el TIA Portal pero no he provado con el wincc mediante OPC Server), despues del modelo nos pide la IP del device, hemos puesto la IP que tiene configurada el LOGO OBA7. En el menu 'timing' lo hemos dejado todo como viene por defecto al igual que en 'auto-demotion'. En 'Comunication-parameters' hemos provado con dos diferentes port number (102 i 10001). En 'S7 Comm. Parameters' hemos provado dejandolo por defecto (4D57) en los dos, poniendo un (2) en los dos y algunos mas aunque todos sin resultado. I para terminar en Adressing Options (Big Endian (S7 default)).

Al terminar esto creamos algun tag (Q0.0, Q1.0) como boleanos y le damos a "Quick Client" y nos dirigimos a nuestro canal para ver los tags. Nos salen con la calidad "Bad" i en value nos sale "Unknown" dandonos a entender que no se comunica con el automata.

No sabemos que hacer ya para comunicar el software con el Logo, cualquier ayuda nos sera de mucha utilidad.

Muchas gracias por todo,

Alex Diaz.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

LabView Ni OPC Server y Logo OBA7 de Siemens.

Publicado por Martin (1 intervención) el 17/01/2014 20:48:11
Hola, pudiste avanzar algo con esto? Porque me pasa algo parecido, el tema es que a mi no me aparece en labview lista de los diferentes opc para elegir, y lo que también me pasa es que no puedo ver los datos ingresados al plc en ni opc server. El plc que estoy utilizandi es ek logo 230rce.
Agradecería muchísimo si me puedes dar una mano.
Saludos!
Martín Dalmao
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

LabView Ni OPC Server y Logo OBA7 de Siemens.

Publicado por sebas (1 intervención) el 06/03/2015 18:16:56
Deben tener instalado la misma version d labview y ni real time y con el mismo service pack, si no le va a generar errores,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

LabView Ni OPC Server y Logo OBA7 de Siemens.

Publicado por Jose Marticorena (1 intervención) el 06/02/2014 17:19:01
Hola,
Quiero aportar a tu tema.
Me parece que la unica forma en que puedes comunicarte con el S7200 es atraves de MODBUS, el cual el S7200, lo tiene desactivida y lo tienes que activar, para que en lugar de comunicarse a traves de PPI, lo haga a travez de MODBUS.

Cuando tengas activado la comunicacion del S7200 en MODBUS, esto es "pan comido" para LABVIEW.

Sin embargo, con LOGO, creo que no hay forma, aunque el medio sea una red erhernet.

Espero te ayude.
saludos cordiales

JAM
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar